tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Diego, Emil" <edi...@exchange.sba.miami.edu>
Subject Unpack WAR Problem
Date Wed, 01 Sep 2004 15:22:33 GMT
Hi,

	I am running tomcat 4.1.27-13 and apache 2.0.49-4 on fedora core 2.  I have configured tomcat
and apache to work together to server JSP pages.  

Now I am trying to install a Java web application.  Here's what I did so far:
1. I copied the war file (opencms.war) into my webapps directory.
2. I created a new xml file for the web application and placed it in the webapps directory.
--- Opencms.xml Content ---
<Context path="/opencms" docBase="/usr/share/tomcat/webapps/opencms.war"
        debug="0" >

  <!-- Uncomment this Valve to limit access to the Admin app to localhost
   for obvious security reasons. Allow may be a comma-separated list of
   hosts (or even regular expressions).
  <Valve className="org.apache.catalina.valves.RemoteAddrValve"
    allow="127.0.0.1"/>
  -->

  <Logger className="com.redhat.tomcat.Logger"
          filename="localhost_opencms.log" timestamp="true"/>

</Context>
--- END CONTENT ---

3. I restarted the tomcat server.
4. The war file didn't get deployed.  

I checked the server.xml file and unpackWARs is set to true in the localhost host entry:
 <!-- Define the default virtual host -->
      <Host name="localhost" debug="0" appBase="webapps"
       unpackWARs="true" autoDeploy="true">



Any ideas what I am doing wrong ????

Emil Diego
Website Administrator
University of Miami School of Business
305.284.5449


---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.744 / Virus Database: 496 - Release Date: 8/24/2004
 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message