tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <mar...@naxos-software.de>
Subject Re: A little offbeat question
Date Thu, 16 Sep 2004 07:24:02 GMT

Try running 'java ... HelloWorld' instead of 'java ... HelloWorld.class'
:-)

Regards,
Martin

John Najarian <j-najarian@earthlink.net> schrieb am 16.09.2004,
09:00:52:
> I tried to run a program I thought would but it doesn't.
> 
> This is on a windows XP platform.
> 
> Everything compiled well but I get this error:
> 
> Exception in thread "main" java.lang.NoClassDefFoundError: HelloWorld/class
> 
>  
> 
> So I went back and tried a no brainer 'HelloWorld'  This is the code.
> 
> /**
> 
>  * The HelloWorld class implements an application that
> 
>  * displays "Hello World!" to the standard output.
> 
>  */
> 
> public class HelloWorld {
> 
>     public static void main(String[] args) {
> 
>         // Display "Hello World!"
> 
>         System.out.println("Hello World!");
> 
>     }
> 
> }
> 
>  
> 
> It compiles but I get the same error.
> 
> I check my environment variables and mine are
> 
> JAVA_HOME c:\j2sdk1.4.2_03
> 
> PATH
> C:\Perl\bin\;C:\j2sdk1.4.2_03\bin\;C:\j2sdkee1.3.1\bin\;%SystemRoot%\system3
> 2;%SystemRoot%;%SystemRoot%\system32\WBEM
> 
>  
> 
> Any ideas?
> 
>  
> 
> Thanks in advance
-- 
Martin Schaefer
NAXOS Software Solutions GmbH i.G.
Herrenstr. 1
69502 Hemsbach
Germany
 
Phone:+49 (0) 6201 49298-2
Mobile: +49 (0) 172 6269246
Fax: +49 (0) 6201 49298-1
Mail: martin.schaefer@naxos-software.de

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message