tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: TC 5.5 - 4 issues (jasper, ROOT, jndi, logging)
Date Thu, 02 Sep 2004 14:11:38 GMT
> > 1/ Jasper has an issue with JSP page imports where the 
> imported packages are not used. This is throwing an exception.
> 
> Did you look at the generated source ?

No, I just removed the imports from my JSP that it was complaining about and it went away.
Would you like me to put them back in and then look at the generated source for you?
 
> > 2/ Had the error mentioned earlier about ROOT child '' 
> cannot be deployed because it was shared by another context. 
> I just removed the ROOT folder from webapps to get rid of 
> that problem.
> 
> Does everyone really think it's a good idea to have Context elements
> in server.xml ?

I don't and I have not. This error occurred with an out of the box server.xml with _no_ Context
elements. All I did was have ROOT and my own webapp in the webapps folder and then add mywebapp.xml
into the conf/C/l/ folder. I think the clash came because my webapp using a path of "" which
seems to be what ROOT tries to do also. Just removing ROOT from webapps sorts this out.
 
> > 3/ None of my JNDI resources configured in 
> tomcat.home/conf/Catalina/localhost/mywebapp.xml are being 
> recognised. This was copied direct from my TC 5.0.25 
> installation ... should this still work? Database JAR is in 
> common/lib. Getting lots of
> > 
> > Cannot create JDBC driver of class '' for connect URL 
> 'null' errors and also in STDOUT
> 
> I noticed the ResourceLink element didn't work at all in 5.5.0: the
> digester rule was simply missing. Besides that, there could be an
> issue with the tweaked DBCP, but that would be surprising.

Is there anything I can do to get Resources working in the meantime again or shall I wait
for the next TC 5.5 release. 
 
> Which happens if the host doesn't have a child with that name, which
> is not normal. How can you possibly get that ?

No idea :) Like I say I have not touched the server.xml _one bit_ after installation. All
I did was add my webapp into webapps and put its config file which just defines jndi resources
into conf/C/l.

> > 4/ The logging suggestion at 
> http://jakarta.apache.org/tomcat/tomcat-5.5-doc/config/logger.
html did not work for me. I have log4j.properties in my webapp classes ... does this override
any other log4j config like in this example?

I'm going to try adding

log4j.logger.org.apache.catalina.=debug, STDOUT

into my webapp log4j and see what that does but first I need my webapp to work :)

If I can be of any help please let me know what you want me to find out..

<FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
-------------------------------------------------------
QAS Ltd.
Developers of QuickAddress Software
<a href="http://www.qas.com">www.qas.com</a>
Registered in England: No 2582055
Registered in Australia: No 082 851 474
-------------------------------------------------------
</FONT>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message