tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: Performance issue
Date Tue, 07 Sep 2004 08:01:14 GMT
it's an interesting one and one that we found too between our dev 1 cpu, w2k, 512mb ram, tomcat
5.0.19 and production 2 cpu, w2k, 1gb ram, tomcat 5.0.19. In both cases we use a content management
system backend and sql server. 

for us we found that the volume of content in our cms on the production box was 10 times that
of the development box and so this slowed the cms down making it look like tomcat was taking
its time. also the sql server load on production is larger so database ops take longer.

you ought to consider whether any dependent backend systems like cms, database, crm etc..
are used in a different way between dev and production. i do not think your problem is tomcat.

cheers, ADC

> -----Original Message-----
> From: Bedrijven.nl [mailto:maarten@bedrijven.nl]
> Sent: 07 September 2004 08:30
> To: 'Tomcat Users List'
> Subject: Performance issue
> 
> 
> Hello all,
> 
> Maybe a rare question but it's very important for us. What's the case:
> 
> * I have a development environment running our applications 
> (simple server,
> WIN 2000 Server, Tomcat 4.0.24, struts, max memorysize appr. 320 MB)
> * I have a production environment running our applications 
> (extended server,
> WIN 2000 Server, Tomcat 4.0.24, struts, max memorysize appr. 1 GB, 4
> processors)
> 
> Now in our applications we have some jsp pages (i.e. 
> searchpages). So what's
> my problem. When I reload a page (submit some action the the 
> form/actionbean
> of struts) it's faster on our development system than on our 
> production
> system. So normally it's should be so that jsp files should 
> be faster on our
> production environment because the server is a lot "bigger". 
> On the other
> hand the compilation of jsp's is faster (as expected) on the 
> production
> environment. Are there some settings in server.xml (or 
> web.xml) that causes
> this???
> 
> Thx in advanced!
> 
> Maarten
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 


<FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
-------------------------------------------------------
QAS Ltd.
Developers of QuickAddress Software
<a href="http://www.qas.com">www.qas.com</a>
Registered in England: No 2582055
Registered in Australia: No 082 851 474
-------------------------------------------------------
</FONT>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message