tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: TC 5.5 - 4 issues (jasper, ROOT, jndi, logging)
Date Thu, 02 Sep 2004 15:47:19 GMT
As regards the JasperException, I have just placed an unused package import to org.apache.struts
back into my error page so that I can post it to you;

org.apache.jasper.JasperException: Unable to compile class for JSP

Generated servlet error:
The import org.apache.struts is never used


	org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:84)
	org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:332)
	org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:354)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:280)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:259)
	org.apache.jasper.compiler.Compiler.compile(Compiler.java:247)
	org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:538)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:296)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:302)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:246)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
	org.apache.jasper.runtime.PageContextImpl.doForward(PageContextImpl.java:670)
	org.apache.jasper.runtime.PageContextImpl.forward(PageContextImpl.java:637)
	org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:785)
	org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:758)
	org.apache.jsp.layout.application_jsp._jspService(org.apache.jsp.layout.application_jsp:314)
	org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
	org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:325)
	org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:302)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:246)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
	org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1069)
	org.apache.struts.tiles.TilesRequestProcessor.doForward(TilesRequestProcessor.java:274)
	org.apache.struts.tiles.TilesRequestProcessor.processTilesDefinition(TilesRequestProcessor.java:254)
	org.apache.struts.tiles.TilesRequestProcessor.processForwardConfig(TilesRequestProcessor.java:309)
	org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:279)
	org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
	org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:507)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
	com.qas.newmedia.common.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:146)


> -----Original Message-----
> From: Remy Maucherat [mailto:remy.maucherat@gmail.com]
> Sent: 02 September 2004 16:15
> To: Allistair Crossley
> Subject: Re: TC 5.5 - 4 issues (jasper, ROOT, jndi, logging)
> 
> 
> On Thu, 2 Sep 2004 15:11:38 +0100, Allistair Crossley
> <allistair.crossley@qas.com> wrote:
> > > > 1/ Jasper has an issue with JSP page imports where the
> > > imported packages are not used. This is throwing an exception.
> > >
> > > Did you look at the generated source ?
> > 
> > No, I just removed the imports from my JSP that it was 
> complaining about and it went away. Would you like me to put 
> them back in and then look at the generated source for you?
> 
> Were the imports not actually used if you were able to remove them
> without problems ? What was the error output ? (why do I have to ask
> this question ?)
> 
> > > > 2/ Had the error mentioned earlier about ROOT child ''
> > > cannot be deployed because it was shared by another context.
> > > I just removed the ROOT folder from webapps to get rid of
> > > that problem.
> > >
> > > Does everyone really think it's a good idea to have 
> Context elements
> > > in server.xml ?
> > 
> > I don't and I have not. This error occurred with an out of 
> the box server.xml with _no_ Context elements. All I did was 
> have ROOT and my own webapp in the webapps folder and then 
> add mywebapp.xml into the conf/C/l/ folder. I think the clash 
> came because my webapp using a path of "" which seems to be 
> what ROOT tries to do also. Just removing ROOT from webapps 
> sorts this out.
> 
> You really need to describe issues accurately (I always find your
> reports extremely weird, unfortunately). I think what you did is that
> you copied over your existing configuration, which will cause
> problems.
> 
> -- 
> xxxxxxxxxxxxxxxxxxxxxxxxx
> Rémy Maucherat
> Developer & Consultant
> JBoss Group (Europe) SàRL
> xxxxxxxxxxxxxxxxxxxxxxxxx
> 


<FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
-------------------------------------------------------
QAS Ltd.
Developers of QuickAddress Software
<a href="http://www.qas.com">www.qas.com</a>
Registered in England: No 2582055
Registered in Australia: No 082 851 474
-------------------------------------------------------
</FONT>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message