tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From A Leg <hale_in...@yahoo.com>
Subject Re: Unable to compile class for JSP
Date Thu, 30 Sep 2004 12:16:29 GMT
Hi

Probably because JWSDP 1.4 force me to use ant of them distrib which is 
1.5xx
and some others elements I use need 1.6.1 or more. So I have both 
releases install 1.6.1is in my classpath and jwsdp ant is set in the 
setenv.sh script.
This must generate a conflict.

I probably have to swictch to tomcat 5.028 which will enable me tu use 
ant1.6.1 for everything. (yes ?)
I use only jsp and servlets. Do I need to download something more than 
Tomcat distrib ?

Best regards

Andre


QM wrote:

>On Thu, Sep 30, 2004 at 11:36:40AM +0300, A Leg wrote:
>: org.apache.jasper.JasperException: Unable to compile class for JSP
>: java.lang.SecurityException: class "org.apache.tools.ant.taskdefs.optional.IContract"'s
signer information does not match signer information of other classes in the same package
>
>Sounds like IContract is in a sealed JAR, and somewhere in the classpath
>there's another copy.
>
>Do you have duplicate JARs, between WEB-INF/lib and Tomcat's various lib
>dirs?
>
>-QM
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message