tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McGrady <m...@michaelmcgrady.com>
Subject Re: Servlet mapping problem
Date Wed, 29 Sep 2004 07:59:53 GMT
Anto Paul wrote:

>Hi all,
>  I am writing an application which have to serve content based on the
>hostname it is requested. Different hosts will be set to same ROOT
>directory. There wont be any content at the ROOT. Everything will be
>on subdirectories. I wrote a servlet with mapping as / . But when it
>is forwarded to subdirectory it is coming to same servlet and
>executing in a loop. This is an example of what I need.
>
>Directory structure.               Host name
>ROOT/sites/one.com -          one.com
>ROOT/sites/two.com            two.com
>ROOT/sites/three.com          three.com
>
>A request to one.com should go to /sites/one.com .
>A request to two.com should go to /sites/two.com .
>
>How to make it.
>
>Thanks in advance
>
>Anto Paul
>
>
>  
>
Hello, Anto,

I don't have enough information to tell what your  problem is.  Are you 
using ActionForwards to go to these areas?  What "servlet" with a 
mapping as / are you talking about?  Remember this is a Struts list.  If 
you have everything mapped to your servlet in your web.xml, then, of 
course, everything is going to go to your servlet.  I suspect this is 
what you have done.  Why do you have a servlet with a "mapping" as "/" ?

Michael McGrady


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message