tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexio Cassani" <cass...@webscience.it>
Subject tomcat 5 and JNI problem
Date Mon, 06 Sep 2004 14:43:06 GMT
Hi all,
I've some trouble running a web application that use JNI to access a dll.
The os is windows 2000/XP and I'm running Tomcat 5.0.26 (tried also with 27
and 28).

I've done the following step:

- put my dll in the %ApacheInstallDir%/common/lib
- started Tomcat service
- open the first page of my web-app with Internet Exploer; this page use the
dll, indeed if I monitor my os during this phase I notice that tomcat5.exe
load the dll

Now, I have another java-based application that use the same dll (same as
logical name, but physically I've placed the dll file in the working dir of
the application) and the same jar file to load it. If I start the
application after I've performed the step 3 I get the following error:

CRC Error! File content has been modified. If you run a system debugger,
clear all breakpoints before running this program!

The only action solve this problem is to stop Tomcat service, so it releases
my dll and I can use it.

I've tried to change the name of the dll, but the problem (this sounds
incredible IMHO :) persists, now I try to change also the name of the jar
invoking the dll.

Any suggestion?
What are the best practices to integrate JNI application with Tomcat?

TIA
Alexio


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message