tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Blaine Barber <bla...@vmunix.com>
Subject Re: JK2 causes SEGV in httpd
Date Tue, 28 Sep 2004 20:52:23 GMT

I've installed the jk2 binary on RedHat and there are no problems there.
I'll try to compile from scratch on Suse... wish me luck!

thnx

-Blaine


In message <20040928014931.GA23302@strange.dreamhost.com>you write:
>On Mon, Sep 27, 2004 at 05:27:33PM -0400, blaine@vmunix.com wrote:
>: I have recently configured Apache 2.0.51 with mod_jk2.so based on the inform
>ation
>: from the book "Professional Apache Tomcat 5", and now all requests
>: to the web server cause a segmentation fault.  :)  Is there something in my
>: config that may be causing this?
>
>A segmentation fault is caused by a dereference error in native code
>(English: C/C++ accessing memory incorrectly, such as trying "*" or "->"
>ops on a null pointer.)
>
>That's a code bug.  It may have been uncovered due to your
>configuration, but certianly not caused by it.
>
>Have you tried a later version of JK2?  You could also try rebuilding
>JK2 from source, so it builds against all of the latest APR headers and
>such.
>
>-QM
>
>
>-- 
>
>software  -- http://www.brandxdev.net
>tech news -- http://www.RoarNetworX.com
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message