tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raul Portales Fernandez <raul...@olidformacion.com>
Subject Access Problem
Date Tue, 14 Sep 2004 10:22:05 GMT
Hello:

I have a very strange problem with tomcat, I have revised te online doc, the 
FAQ, and googled it, but found nothing. Here is it:

I have a webapp installed by a .war file, this app works fine when I acces it 
by localnet using:

http://myinternalip:myport/myapp/

The whole app works fine. I also have Port Forwarding set in the router, but 
when I try to access it form an external IP, using:

http://myexternalip:myport/myapp/

it does not work, and I get the following error:

javax.servlet.ServletException: Exception opening resource 
http://myexternalip:myport/myapp/somedir/somepage.jsp;jsessionid=someid: 
java.net.ConnectException: Connection refused
        org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:862)
        org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:795)
        org.apache.jsp.index_jsp._jspService(index_jsp.java:238)
        org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:133)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
        org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:311)
        org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:301)
        org.apache.jasper.servlet.JspServlet.service(JspServlet.java:248)
        javax.servlet.http.HttpServlet.service(HttpServlet.java:856)

More strange even is that if you try to access to the URI that gives the 
problem putting it in the addess bar of the browser:

http://myexternalip:myport/myapp/somedir/somepage.jsp;jsessionid=someid:

It works!, but obviously just for this page, wich is included in the index 
page.
Moreover, there are other applications installed in the same tomcat, and they 
work from local and external networks.

Has anyone any idea of the possible source of the problem.

I'm using Tomcat 5.0.14 in a FreeBSD box. The same error happens in a W2k box 
with 5.0.16

Thank's in advance.
-- 
Un saludo, por ejemplo, buenos dias:

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message