tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Johnson <pe...@wizardslair.net>
Subject Re: Integrating Tomcat 5 and Apache 2
Date Tue, 28 Sep 2004 23:16:08 GMT
Stewart,

Try enabling the RequestDumperValve in server.xml. I think you'll find
it has something to do with the difference between
"com.datatel.server.servlets.webadvisor.WebAdvisor" and
"datatel/openweb" ... well that is my first thought anyway.

PJ

On Wed, 2004-09-29 at 08:28, Stewart Walker wrote:
> Redhat Linux Enterprise
> httpd-2.0.46-40.ent
> j2sdk1.4.2_05
> tomcat-5.0.27
> jakarta-tomcat-connectors-jk2-2.0.4-src
> 
> For the record.. If I run the servlets 
> 
> http://server.edu:8080/servlet/com.datatel.server.servlets.webadvis
> or.WebAdvisor?ACTION=Login
> they work fine.
> 
> 
> Going over the 
> Chapter 8. Integrating Tomcat 5 and Apache 2 at
> http://cymulacrum.net/writings/tomcat5/c875.html
> Everthing (./confgure, make & ldd ) went fine.
> Found that the
> $CATALINA/logs/jk2.shm and the jk2.socket files.
> For some reason arn't being created when tomcat starts.
> 
> Tomcat isn't complaining about anything as far as I can tell.
> 
> 2004-09-28 15:53:34 StandardContext[]WebAdvisor: Initializing 
> WebAdvisorContext
> 2004-09-28 15:53:34 StandardContext[]WebAdvisor: No cache 
> found, creating new session cache.
> 2004-09-28 15:57:09 StandardContext[/servlets-
> examples]InvokerFilter(ApplicationFilterConfig[name=Path Mapped 
> Filter, filterClass=filters.ExampleFilter]): 4 milliseconds
> 
> Tomcat starts and stops and serves the pages when directed as 
> above.
> 
> Went back thru 
> Chapter 8. Integrating Tomcat 5 and Apache 2
> Appendix A. mod_jk2 404 Error Problem 
> Appendix C. Building mod_jk2 on Red Hat Enterprise Linux 3 
> (RHEL) 
> double checked everything.
> 
> Went ahead and started httpd and tried the uri setting 
> 
> # Uri mapping for datatel
> [uri:/datatel/openweb/*]
> 
> in workers2.properties and 
> got the 404 error. 
> 
> Commented out the uri settings there and put
> 
> <Location "/datatel/openweb/*">
> JkUriSet worker ajp13
> </Location>
> 
> in etc/httpd/conf/httpd.conf 
> 
> Gave it a shot and recieved
> 
> 500 Internal Server Error
> (httpd error log logged )
> [Tue Sep 28 15:45:36 2004] [error] uriEnv.init() map to invalid 
> worker /datatel/openweb/*-0 ajp13
> and
> [Tue Sep 28 15:57:32 2004] [error] mod_jk2.handle() No worker for 
> /datatel/openweb/index.html
> When I tried index.html
> 
> I'm almost there was hoping some one would have an idea on what
> is going on
> 
> Thanks
> 
>                  \\|//
>               -(@ @)-
> ===oOO==(_)==OOo======================
> 
> Stewart Walker
> swalker@caspercollege.edu
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message