tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rafal Markut" <rafal.mar...@mediawave.de>
Subject Session ID in a URL - doesn't work
Date Wed, 15 Sep 2004 12:57:35 GMT
Hello,

I want to use session per URL. I have application which name is "test".
I added into conf/server.xml: <Context path="/test" docBase="test"
cookies="false"/>

I wrote a small JSP page (of course with <%@ page session="true" %>) to
test if it works. Unfortunately when it calls new page then it always
creates new session (so it means that information saved in session in
previous page doesn't exist anymore). I don't see in the URL any
information about session ID.

What is interesting/strange ... when I typed cookies="false" and I
blocked all cookies in my browser then it works! But it shouldn't work.


Tomcat version: 4.1.30
My application looks like that:
It has two directories: jsp and WEB-INF.
I have in "jsp" directory only this jsp page for testing.

In WEB-INF I have only one web.xml:
<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
    "http://java.sun.com/dtd/web-app_2_3.dtd">

<web-app>

    <display-name>My test</display-name>
    <description>
      My test
    </description>

</web-app>

Did somebody have problem like that?
I make something wrong but I don't know what ;-)

Best regards,
Rafal


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message