tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Krzysztof Cieniuch" <cieni...@o2.pl>
Subject Tomcat 5.0.28 form post encoding problem
Date Fri, 17 Sep 2004 14:42:36 GMT
Hi I've got problem (again)  with encoding.
Yes I've read all bugs  23929 25360 etc.
No I didn't read www.anassina.com/struts/i18n/i18n.html because I can't
reach that site don't know why server down or my connection broken???

I've got two jsp pages index.jsp and out.jsp
On index.jsp I have simple form with one text input field (the name of this
text field is "user")
on out.jsp  page  I read that input with line like this
request.getParameter("user")
and of course when I use some national characters i.e not iso-8859-1 then I
get ??? on the out.jsp page
when i use
new
String(request.getParameter("user").getBytes("ISO-8859-1"),"ISO-8859-2");
everything is ok
I've tried everything :
-setting encoding
   -- in html meta tag
   -- in jsp page tag
   -- i use method Post in that  form

nothing works the browser allways sends data encoded in ISO-8859-1
so using through all my pages syntax like this
new
String(request.getParameter("user").getBytes("ISO-8859-1"),"ISO-8859-2");
is the only solution ??
I would like to use jsp and struts tags and then this is not an option
bean:write tag also gives ??? on national characters
I've changed server.xml connector  part and added URIencoding="ISO-8859-2"
and useBodyEncodingForURI=true this either doesn't help
and since I'm sending form data in body part of the request how should this
help anyhow

HELP the lost newbi :-)))

KC


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message