tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Younes El Moumen" <Younes.ElMou...@ton-art.de>
Subject AW: JSTL Problem on Tomcat
Date Thu, 12 Aug 2004 14:48:36 GMT
yes it works thank you :-)

I've copied the tld files to my WEB-INF and added the Taglibs at the of my web.xml.

-----Urspr√ľngliche Nachricht-----
Von: Peter Huesser [mailto:peter.huesser@psi.ch]
Gesendet: Donnerstag, 12. August 2004 15:02
An: Tomcat Users List
Betreff: Re: JSTL Problem on Tomcat



>when I try to validate this code:
>
>                            <c:if test='${!empty param.con}'>
>                                <c:import url="/content.jsp"/>
>		</c:if>
>I become an Error:
>According to TLD or attribute directive in tag file, attribute test does not accept any
expressions
>
>does anyone know what's wrong and how to solve this problem.
>  
>
I had the same problem. Read the following article: 
"http://www.javaworld.com/javaworld/jw-02-2003/jw-0228-jstl.html". I had 
to copy the *.tld files somewhere to the WEB-INF directory and add in 
the web.xml file the <taglib> directives as described. The article 
describes the two flavors of the JSTL library (see paragraph JSTL tag 
libraries). I am using tomcat version 5.0.19 and 5.0.25 together with 
the newest J2EE release. If you are using older releases the problem may 
have its origin somewhere else.

Pedro



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message