tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugene <j.subscr...@bk.ru>
Subject java.io.UTFDataFormatException
Date Fri, 27 Aug 2004 22:07:42 GMT
Hello All! I've fix this error with XSLT generation. I've copyed xalan.jar from 2jars to 'endorsed'
folder of Tomcat and I've created the copy of this folder in lib of JRE. Thanks to Jake for
his help!!!

Now I have another problem with generation of this page. When I'm trying to pass the data
to servlet it returns this error:
java.io.UTFDataFormatException: Invalid byte 2 of 2-byte UTF-8 sequence.

This app worked fine before on old Tomcat4.0.27 and Apache 2.0.46 with mod_jk.

Is this a bug???
I'm running Win 2003, Apache2.0.50+Tomcat5.0.27. I've tryed to run it with JDK 1.5Beta2 then
I've installed JDK 1.4.2_05 - without any progress. The only difference that I have - its
when I'm using JDK 1.4.2 its a little slower then 1.5. But its produces the same exception.
What should I do??? (the first answer I have - its kill myself:)) Seriously - what is it?
Xalan, Xerces or what?

The Java console of the browser tells this:
Create XSLTINFO
documentURL : XSLT.xslt
In LayerQueryInfo
LayerID =areas
propertyName =PropertyFilter
value =perimeter>207911
create an Hastable for the layer
--- Hastable ---{PropertyFilter=perimeter>207911}
DOCUMENT =
<LayerInfoRequest directOutput="true">
    <LayerQuery fullEnvelope="false" envelope="false" layerid="areas_geo">
        <PropertyFilter>perimeter&gt;207911</PropertyFilter>
    </LayerQuery>
    <Output>
        <XSLTInfo>
            <DocumentURL>XSLT.xslt</DocumentURL>
        </XSLTInfo>
    </Output>
</LayerInfoRequest>

Here I see the problem when I'm trying to pass the data in <PropertyFilter /> parameter
- its 
converted automatically from "perimeter>207911" to "perimeter&gt;207911". But I cant
tell is that a real problem or not, because I just dont remember how it worked before - with
this converion or not.

Any suggestions how to fix this???

Thank you very much in advance!

--
Best regards,
 Eugene  

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message