tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shilpa Nalgonda" <>
Subject RE: access denied
Date Tue, 24 Aug 2004 19:50:04 GMT
I added the below line in the general grant{} block.
permission "C:\\Program Files\\Apache Group\\Tomcat
4.1\\certs\\-", "read";

I tried placing the certs file in other directory too where there is no
whitespace issue.  But i still have the problem.
can you think of anything else?

-----Original Message-----
From: Benjamin Armintor []
Sent: Tuesday, August 24, 2004 3:32 PM
To: Tomcat Users List
Subject: RE: access denied

Where did you add the permission in the catalina.policy file?  In a
general "grant{}" block?
If not, it's possible that your code doesn't have the permission.

It may also be the case that the whitespace in the filepath causes
problems, but someone who actually runs on Windows could tell you better
than I.

Benjamin J. Armintor
Operations Systems Specialist
ITS-Systems: Mainframe Group
University of Texas - Austin
tele: (512) 232-6562

-----Original Message-----
From: Shilpa Nalgonda []
Sent: Tuesday, August 24, 2004 1:51 PM
Subject: access denied

I am running Tomcat4.1.30 on windows 2000, with security option turned
on. My java application which is using JDK 1.4, connects to the the
credit card authorizing company called verisign, and returns the
approval authorization code. I have installed the digital certificate
on $TOMCAT_HOME\certs directory. There are read permissions on the cert
file. But still for some reason the verisign is not able to read the
cert file due to the below error.

RESULT=-31&RESPMSG=The certificate chain did not validate, no local
certificate found, access denied
( on C:\Program Files\Apache Group\Tomcat 4.1\certs

However when i run Tomcat server without security, everything is file.
Somehow tomcat is restricting the permission to read the cert file.

Verisign uses Jsse.jar to do the security authentication.
I have modofied both java.policy and catalina.policy to grant permission
on the cert file as below. permission
"C:\\Program Files\\Apache Group\\Tomcat 4.1\\certs\\-", "read";

But this does not help, is there anything else i should do to the
server.xml file...

How does the security manager runs in Tomcat4.1
Please help...

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message