tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Wingfield <jon.wingfi...@mkodo.com>
Subject Re: Tomcat error
Date Wed, 04 Aug 2004 15:49:33 GMT
The 49.0 is a magic number within the class bytecode. This type of error 
typically means the class was compiled using a newer version of the jdk 
than the runtime that is interpreting the bytecode. So, did you, say, 
compile the lawSearch class using jdk 1.5 but are running Tomcat against 
  jdk 1.4?

Resolution: recompile lawSearch against jdk 1.4

http://java.sun.com/docs/books/vmspec/2nd-edition/html/ClassFile.doc.html#75883

HTH,

Jon

Schalk Neethling wrote:
> Hey there all
> 
> I get the following line when running my servlet on Tomcat version 5.0.25:
> 
> java.lang.UnsupportedClassVersionError: 
> org/volume4/searchEngine/lawSearch (Unsupported major.minor version 49.0)
> 
> What exactly does this mean and how do I go about fixing this? Thanks!
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message