tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Samuel V. Green III <macun...@cox.net>
Subject Re: [tomcat] Re: Understanding tomcat web administration tool.
Date Sun, 01 Aug 2004 01:48:41 GMT
Thanks Ernesto.

I copied your code , restarted tomcat and still no luck with getting 
admin tool to load.
Although Manager does work?

Samuel.
On Jul 31, 2004, at 5:52 PM, Ernesto Echeverría wrote:

> What about deleting the 2nd tomcat user definition? You can use
> roles="tomcat,admin,manager".
>
> Take a look at my file:
>
> <?xml version='1.0' encoding='utf-8'?>
> <tomcat-users>
>   <role rolename="tomcat"/>
>   <role rolename="role1"/>
>   <role rolename="manager"/>
>   <role rolename="admin"/>
>   <user username="tomcat" password="tomcat"
> roles="tomcat,role1,manager,admin"/>
>   <user username="role1" password="tomcat" roles="role1"/>
>   <user username="both" password="tomcat" roles="tomcat,role1"/>
>   <user username="ernestoe" password="ernestoe"
> roles="tomcat,role1,manager,admin"/>
> </tomcat-users>
>
>
> José Ernesto Echeverría
> ernestoe@telemovil.net
> Tel. (503)8859011
>
>
> -----Original Message-----
> From: Samuel V. Green III [mailto:macunkie@cox.net]
> Sent: Sábado, 31 de Julio de 2004 06:41 p.m.
> To: Tomcat Users List
> Subject: [tomcat] Re: Understanding tomcat web administration tool.
>
>> Hi,
>> Out of the box, you don't need to edit admin.xml or manager.xml.  You
>> just need to add a user with roles of admin and manager to the
>> tomcat-users.xml file and restart the server.
>>
>> Yoav Shapira
>> Millennium Research Informatics
>>
>>
>
>
>
>
> I'm still having problems getting Admin Tool to work:
>
> Here is my interpretation of editing tomcat-users.xml to get it to 
> work.
>
> <?xml version='1.0' encoding='utf-8'?>
> <tomcat-users>
>    <role rolename="tomcat"/>
>    <role rolename="role1"/>
>    <role rolename="manager"/>
>    <role rolename="admin"/>
>    <user username="tomcat" password="tomcat" roles="admin,manager"/>
>    <user username="tomcat" password="tomcat" roles="tomcat"/>
>    <user username="both" password="tomcat" roles="tomcat,role1"/>
>    <user username="role1" password="tomcat" roles="role1"/> 
> </tomcat-users>
>
> What am I doing incorrect?
>
> Thanks,
>
> Samuel.
>
>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message