tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dale, Matt" <Matt.D...@beCogent.com>
Subject RE: Stopping takes ages
Date Thu, 29 Jul 2004 14:55:30 GMT

It sounds like its possible that error could be causing the problem. I would suggest switching
to either JK or JK2 connectors to connect to your webserver as they are still being developed,
unlike Warp.

Ta
Matt

-----Original Message-----
From: Christina Androne [mailto:achristina@home.ro]
Sent: 29 July 2004 15:52
To: Tomcat Users List
Subject: Re: Stopping takes ages


Hi

Just a wild guess, can be because of this error that keeps showing up in 
the logs?

2004-07-29 01:42:32 [org.apache.catalina.connector.warp.WarpConnector] 
Error accepting requests
java.net.SocketException: Socket closed
   at java.net.PlainSocketImpl.socketAccept(Native Method)
   at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:353)
   at java.net.ServerSocket.implAccept(ServerSocket.java:448)
   at java.net.ServerSocket.accept(ServerSocket.java:419)
   at org.apache.catalina.connector.warp.WarpConnector.run(Unknown Source)
   at java.lang.Thread.run(Thread.ja

The tomcat version is 4.1.29, OS is red hat 8 and jdk 1 .4.2_03. But the 
biggest problem is not that stopping is slow, but that the browser does 
not get response from the servlet. I've placed debug messages in the 
servlet so I am sure it does not hang inside of it.

Christina

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message