tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Birt, Jeffrey" <bi...@umr.edu>
Subject RE: Newbie question: Error 503 Service Temp. Unavailable
Date Fri, 09 Jul 2004 13:06:25 GMT
I too am running Linux (Fedora 1).  Another chap posted after me having
similar problems with Windows (IIS).  I've confirmed that apache is
running as user apache which belongs to the group apache.  User tomcat
of the group tomcat owns the tomcat directory (and I'm running tomcat as
user tomcat).  I've added the apache group to the tomcat group (I think)
like this

#usermod -G apache,tomcat apache

I read through some more of the Tomcat 5 docs last night and I'll give
it another whack today.

Thanks,

Jeff Birt
Electronics Engineer
Integrated Systems Facility
University of Missouri - Rolla
573.341.6058 


-----Original Message-----
From: Tim Wills [mailto:admin@yorweb.co.uk] 
Sent: Thursday, July 08, 2004 11:18 PM
To: Birt, Jeffrey
Cc: Tomcat Users List
Subject: RE: Newbie question: Error 503 Service Temp. Unavailable

I had the same Error 503 on Linux (not Windows) and found that was
caused by
Apache running as Nobody. Apache couldn't write to the socket because
the
owner was tomcat and Nobody was not a member of the group tomcat.

Check your apache error_log and see what it says. I have never run a
Windows
server so can't be more helpful.

Cheers

Tim




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message