tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Allen <e...@svallens.com>
Subject tomcat 5.0.27 is giving me trouble
Date Thu, 29 Jul 2004 21:50:03 GMT
My gentoo box apparently just upgraded to tomcat 5.0.27 last night and 
it's completely screwed up my setup. It used to be that tomcat would 
reside in /opt/tomcat (conf in /etc/tomcat, which was symlinked to from 
within /opt/tomcat), my app detail .xml files in 
/opt/tomcat/conf/Catalina/localhost and most of my apps in 
/home/eric/workspace and I could start it either with /etc/init.d/tomcat 
or eclipse. Everything was great. Then I upgraded. Apparently, gentoo 
tried to migrate everything to /opt/tomcat5 and /etc/tomcat5 but it 
didn't do a very good job. I got it to start from the init script, 
although it's log was very crabby (attached). I changed the location of 
tomcat from in eclipse and tried to start it and got the below response. 
What is wrong?!

Can't load server.xml
Can't load server.xml
Jul 29, 2004 2:44:59 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 0 ms
java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:284)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:422)
Caused by: java.lang.NullPointerException
    at org.apache.catalina.startup.Catalina.await(Catalina.java:619)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:579)
    ... 6 more



Mime
View raw message