tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien GALLET <sgal...@ibourgogne.net>
Subject Re: JK 1.2.6 released
Date Tue, 27 Jul 2004 10:45:44 GMT
Mario Guenterberg a écrit :

>On Tue, Jul 27, 2004 at 11:25:03AM +0200, Sébastien GALLET wrote:
>  
>
>>I can't compile mod_jk with my debian (sarge)
>>Here is the log
>>
>>make[2]: entrant dans le répertoire « 
>>/var/data1/neo/apache/TMP/libapache2-mod-jk/src/jk/native/common »
>>/bin/sh /usr/share/apache2/build/libtool --silent --mode=compile gcc 
>>-I/usr/include/apache2 -g -O2 -DHAVE_JNI -I/usr/include/apr-0 -pipe 
>>-I/usr/include/xmltok -I/usr/include/openssl -O2 -pipe 
>>-I/usr/include/xmltok -I/usr/include/openssl -O2 -pthread -DHAVE_APR 
>>-I/home/thom/packages/apache2-2.0.49/build-tree/apache2-build/worker/srclib/apr/include

>>/home/thom/packages/apache2-2.0.49/build-tree/apache2/srclib/apr/include -g 
>>-O2 -DHAVE_JNI -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE 
>>-D_SVID_SOURCE -D_GNU_SOURCE -I /usr/lib/j2se/1.4/include -I 
>>/usr/lib/j2se/1.4/include/linux -c jk_ajp12_worker.c
>>gcc: cannot specify -o with -c or -S and multiple compilations
>>make[2]: *** [jk_ajp12_worker.lo] Erreur 1
>>    
>>
>
>First of all, sorry for my english.
>  
>
Mine is not better than yours ;)

>On debian sarge you need the apache2-dev package. 
>  
>
package apache2-threaded-dev is installed on my sarge.
I've made a package for the 1.2.5 release, and when i try to update to 
1.2.6 ... that doesn't work

>This is not installable - at this time.
>mod_jk needs the APR source for compile.
>I be solved this problem:
>
>1. Removed the debian apache2 packages and the dependencies
>  
>
I can't do that. I use many apache2 modules (mod_ldap_userdir, ..) 
installed as package.  And i need to recompile all of them

>2. Installed the apache-2.0.x by hand (configure/make/make install)
>3. Installed the Tomcat-4.x/5.x
>4. Installed the mod_jk
>
>It works fine.
>
>I use Apache-2.0.50/Tomcat-5.0.27/
>jakarta-tomcat-connectors-jk2-2.0.4, but the problem
>you've write is on other versions the same.
>greetings
>Mario
>
>  
>
greetings
Sébastien

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message