tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Bragg <li...@gmnet.net>
Subject Re: jk2, apache2, tomcat5, on redhat 9 issue
Date Sun, 25 Jul 2004 15:08:12 GMT
Mark Eggers wrote:
> You will need to install the httpd-devel rpm as well.  This will give
> you apxs and other material needed to compile mod_jk2.  You might check
> on yum to see if mod_jk2 is already compiled.  It is for Fedora Core 2. 
> I don't know if it is for Redhat 9.
> 
> I build my own Apache, mod_jk2, etc. from source so all I can tell you
> is what Synaptic, yum, and rhn tell me.
> 
> /mde/
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 


Thanks Mark! That did the trick for that, however, I am getting problems 
when I run apxs after the make.

------
# /usr/sbin/apxs -n jk2 -i mod_jk2.so
/usr/lib/httpd/build/instdso.sh 
SH_LIBTOOL='/usr/lib/httpd/build/libtool' mod_jk2.so 
/usr/lib/httpd/modules
/usr/lib/httpd/build/libtool --mode=install cp mod_jk2.so 
/usr/lib/httpd/modules/
cp mod_jk2.so /usr/lib/httpd/modules/mod_jk2.so
mv: cannot move `/usr/lib/httpd/modules/' to a subdirectory of itself, 
  `/usr/lib/httpd/modules/mod_jk2.so.so'
chmod 755 /usr/lib/httpd/modules/mod_jk2.so
chmod: failed to get attributes of `/usr/lib/httpd/modules/mod_jk2.so': 
No such file or directory
apxs:Error: Command failed with rc=65536
------

My apache2 install is in /etc/httpd not /usr/lib/httpd so I don't know 
why it is trying put the module there.

After I ran that, I copied the mod_jk2.so to /etc/httpd/modules/. but 
then apache does not work:

I put this line in httpd.conf:
LoadModule jk2_module modules/mod_jk2.so

then ran this test:

------
# /usr/sbin/httpd -t
Syntax error on line 213 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/mod_jk2.so into server: 
/etc/httpd/modules/mod_jk2.so: undefined symbol: apr_socket_send
------

I'm not sure how to fix this
Does anyone have any suggestions?

Thanks again!
Rick







---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message