tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From E <middlewareli...@intracommunicate.com>
Subject not getting connection leak stacktraces
Date Wed, 21 Jul 2004 02:03:30 GMT
Tomcat's reporting some connection leaks in my application...but I can't 
figure out where they're coming from. The only output i see in my logs is:
AbandonedObjectPool is used 	 
(org.apache.commons.dbcp.AbandonedObjectPool@ff45de)
    LogAbandoned: true
    RemoveAbandoned: true
    RemoveAbandonedTimeout: 60

I'm running Tomcat 5.0.27, connecting to MySQL 12.22 using 
mysql-connector 3.0.11. My connection pool is setup as follows:

     <Resource name="jdbc/writer" auth="Container" 
type="javax.sql.DataSource"/>
     <ResourceParams name="jdbc/writer">
         <parameter>
             <name>factory</name>
             <value>org.apache.commons.dbcp.BasicDataSourceFactory</value>
         </parameter>

         <parameter>
             <name>maxActive</name>
             <value>10</value>
         </parameter>

         <parameter>
             <name>maxIdle</name>
             <value>2</value>
         </parameter>

         <parameter>
             <name>maxWait</name>
             <value>10000</value>
         </parameter>

         <parameter>
             <name>removeAbandoned</name>
             <value>true</value>
         </parameter>

         <parameter>
             <name>removeAbandonedTimeout</name>
             <value>60</value>
         </parameter>

         <parameter>
             <name>logAbandoned</name>
             <value>true</value>
         </parameter>

         <parameter>
             <name>username</name>
             <value>XXX</value>
         </parameter>
         <parameter>
             <name>password</name>
             <value>XXX</value>
         </parameter>

         <parameter>
             <name>driverClassName</name>
             <value>com.mysql.jdbc.Driver</value>
         </parameter>

         <parameter>
             <name>url</name>
 
<value>jdbc:mysql://localhost:3306/mydatabase?autoReconnect=true</value>
         </parameter>
     </ResourceParams>

I can't see any obvious leaks in my code, so I'm completely baffled. Any 
help is appreciated.

-e

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message