tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Smith <d...@cornell.edu>
Subject Re: apache2 crashes when using connectors - nobody?
Date Tue, 06 Jul 2004 15:19:54 GMT
Well, a quick off the bat error:

    JkMount /examples/servlet/* ajp13
    JkMount /examples/*.jsp ajp13

These should read:

JkMount /examples/servlet/*  worker1
JkMount /examples/*.jsp   worker1

The name you gave your workers in workers.properties has to be used in you JkMount statements.

--David



Andy Spiegl wrote:

>Hi David,
>
>thanks for your reply.
>
>  
>
>>Someone might be able to help if you would be so kind as to provide more 
>>information like relevant parts of your Apache config
>>    
>>
>-------8<-------8<------
><IfModule mod_jk.c>
>
>    JkWorkersFile /opt/jakarta/tomcat/conf/workers.properties
>    JkLogFile /opt/jakarta/tomcat/logs/mod_jk.log
>
>    # Log level to be used by mod_jk
>    JkLogLevel debug
>#    JkLogLevel error
>
>    # The following line makes apache aware of the location of
>    # the /examples context
>    Alias /examples "/opt/jakarta/webapps/examples"
>    <Directory "/opt/jakarta/webapps/examples">
>    Options Indexes FollowSymLinks
>    allow from all
>    </Directory>
>
>    # The following line mounts all JSP files and the /servlet/ uri to tomcat
>    JkMount /examples/servlet/* ajp13
>    JkMount /examples/*.jsp ajp13
>
>    # The following line prohibits users from directly accessing WEB-INF
>    <Location "/examples/WEB-INF/">
>    AllowOverride None
>    deny from all
>    </Location>
>
></IfModule>
>-------8<-------8<------
>
>  
>
>>and the workers.properties file.
>>    
>>
>-------8<-------8<------
># Define some properties
>workers.apache_log=/var/log/apache2/
>workers.tomcat_home=/opt/jakarta/
>#workers.java_home=/opt/IBMJava2-131/
>ps=/
># Define 1 worker
>worker.list=worker1
># Set properties for worker1 (ajp13)
>worker.worker1.type=ajp13
>worker.worker1.host=localhost
>worker.worker1.port=8009
>-------8<-------8<------
>
>  
>
>>Also was the mod_jk connector package you installed built for this
>>version of Apache?
>>    
>>
>Hm, I think so.  I tried:
> apache2-jakarta-tomcat-connectors-4.1.27-63.i586.rpm
> apache2-jakarta-tomcat-connectors-4.1.27.tgz
>and
> http://www.apache.de/dist/jakarta/tomcat-connectors/jk2/binaries/linux/Suse-9.0-i386.tar.gz
>
>Thank you for any help!
> Andy.
>
>  
>

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message