tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bioinfo Gu <bioinfowis...@yahoo.com>
Subject RE: Tomcat 5.0.27 deploy problem
Date Wed, 21 Jul 2004 17:12:52 GMT
Hello Shapira,
 
I solve the deploy problem. I change the web.xml file. When I use 'ant install', now there
is no error any more. But the problem I have only one servlet program 'Hello.java' in 'mypackage'
package. After I deployed mytest, how can I access my servlet mypackage.Hello.
 
Here is my simple web.xml:
[root@hydra12 WEB-INF]# more web.xml
<?xml version="1.0" encoding="ISO-8859-1"?>
<!--
-->
<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
    version="2.4">
  <display-name>Welcome to Tomcat</display-name>
  <description>
     Welcome to Tomcat
  </description>

<!-- JSPC servlet mappings start -->
    <servlet>
        <servlet-name>hello</servlet-name>
        <servlet-class>mypackage.Hello</servlet-class>
    </servlet>
<!--
    <servlet-mapping>
        <servlet-name>org.apache.jsp.index_jsp</servlet-name>
        <url-pattern>/index.jsp</url-pattern>
    </servlet-mapping>
-->
<!-- JSPC servlet mappings end -->
</web-app>

Thank you very much,
 
Gu

"Shapira, Yoav" <Yoav.Shapira@mpi.com> wrote:

Hi,
Check $CATALINA_HOME/logs for any errors and post them if found.

Yoav Shapira
Millennium Research Informatics


>-----Original Message-----
>From: bioinfo Gu [mailto:bioinfowistar@yahoo.com]
>Sent: Wednesday, July 21, 2004 12:05 PM
>To: tomcat-user@jakarta.apache.org
>Subject: Tomcat 5.0.27 deploy problem
>
>Hello Everybody,
>
>I am installing Tomcat 5.0.27 on Fedora Linux. I have make one new
>application for testing in tomcatroot/webapps/mytest. I am using 'ant'
to
>deploy my application mytest.
>
>Here is the srceenshot:
>
>[root@hydra12 mytest]# ant install
>Buildfile: build.xml
>prepare:
> [mkdir] Created dir: /usr/local/jakarta-tomcat-
>5.0.27/webapps/mytest/build
> [mkdir] Created dir: /usr/local/jakarta-tomcat-
>5.0.27/webapps/mytest/build/WEB-INF
> [mkdir] Created dir: /usr/local/jakarta-tomcat-
>5.0.27/webapps/mytest/build/WEB-INF/classes
> [copy] Copying 1 file to /usr/local/jakarta-tomcat-
>5.0.27/webapps/mytest/build
> [mkdir] Created dir: /usr/local/jakarta-tomcat-
>5.0.27/webapps/mytest/build/WEB-INF/lib
>compile:
> [javac] Compiling 1 source file to /usr/local/jakarta-tomcat-
>5.0.27/webapps/mytest/build/WEB-INF/classes
>install:
> [deploy] OK - Deployed application at context path /mytest
>
>BUILD SUCCESSFUL
>Total time: 2 seconds
>[root@hydra12 mytest]#
>
>>From Tomcat web application manager, I can see mytest application, but
I
>can not start it, the error is :
>
>FAIL - Application at context path /mytest could not be started
>
>when I click mytest from web application manager page:
> The requested resource (/mytest/) is not available.
>
>I am new to Tomcat, could anybody points out where I am wrong?
>
>Thanks a lot,
>
>Gu
>
>
>
>---------------------------------
>Do you Yahoo!?
>Yahoo! Mail - Helps protect you from nasty viruses.



This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged. This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else. If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender. Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


		
---------------------------------
Do you Yahoo!?
Yahoo! Mail is new and improved - Check it out!
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message