tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sarojini chowdary <sakhamur...@yahoo.co.in>
Subject problems with mod_jk2
Date Sun, 11 Jul 2004 18:38:32 GMT
Please Help... 
  Hi, 
  I have problem with mod_jk2.so 
  I have installed redhat 9 and I used the default 
  version of apache that came with redhat 9 i.e. 
  apache/2.0.40 
  and I installed and configured tomcat 5.0.25. 
  Till now both work fine when I start them alone. 
  I have installed mod_jk 2 connector latest version 
  i.e. jakarta-tomcat-connectors-jk2-2.0.4-src. 
  I restarted tomcat. 
  And when I look at CATALINA_OUT I see this line. 
  INFO: APR not loaded, disabling jni components: 
  java.io.IOException: java.lang.UnsatisfiedLinkError:

  /usr/local/apache2/modules/jkjni.so: 
  /usr/local/apache2/modules/jkjni.so: undefined 
  symbol: 
  apr_md5_final 
  When I try to use apu-config to know the list of
libraries to attach it says the command is not found.
  After this point, when I try to restart apache it 
  gives this error. 
  Starting httpd: Syntax error on line 157 of 
  /etc/httpd/conf/httpd.conf: 
  Cannot load /etc/httpd/modules/mod_jk2.so into 
  server: 
  /etc/httpd/modules/mod_jk2.so: undefined symbol: 
  apr_socket_send 
  
  [FAILED] 
  I was trying to fix it right from past 2 days and I 
  could not do it. 
  Please tel me what I should do. 
  Thanks in advance. 
  Sarojini. 
  IndusRAD Inc. 
  Peoria, IL, 61606 
  USA 
  309-691-0591 


________________________________________________________________________
Yahoo! India Careers: Over 50,000 jobs online
Go to: http://yahoo.naukri.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message