tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gopalakrishnan" <tg...@rediffmail.com>
Subject Problem while calling servlet.......
Date Thu, 08 Jul 2004 03:59:12 GMT
  
Hai
I am trying to compile and .jrxml file created by iReport to create .jasper file by calling
compileReport() method of jasperreport package.
While trying to compile .jrxml file using jasper report it create a intermediate .java file
and by using that it creates the .jasper file. After compilation it deletes that .java file.
The .java file intern refers some packages of jasper report.
While i tried the thing with standalone example it worked, but when i tried the same thing
from a servlet it throws error of classNotFoundException for the all the classes refered by
the intermediate .java file created by the jasper report(java file is created at tomcat's
root directory).
jasperreport.jar is in classpath and i tried to compile the created .java file manually(using
textpad) it works, but it is 
not working when we call the compileReport() method from servlet.
I am using Tomcat 5 and jasper report 0.5.3
Pls help me to solve this

Thanks
T.Gopalakrishnan


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message