tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashish-Kumar.Bal...@alcatel.co.in
Subject Re: AJP13 connection problem
Date Wed, 23 Jun 2004 10:06:47 GMT

Just to add more information...
I am using Tomcat 4.1.24 and Apache 1.3.19

Following are the contents of the workers.properties
      worker.list=loadbalancer

      worker.tomcat0.type=ajp13
      worker.tomcat0.host=nil102
      worker.tomcat0.port=8009
      worker.tomcat0.lbfactor=100

      worker.loadbalancer.type=lb
      worker.loadbalancer.balanced_workers=tomcat0

Following are the changes to httpd.conf

      LoadModule jk_module libexec/mod_jk.so
      AddModule mod_jk.c

      <IfModule mod_jk.c>
              JkWorkersFile
/in/slee/webserver/apache/conf/workers.properties
              JkMount /servlet/* loadbalancer
              JkLogFile /in/slee/webserver/apache/logs/JK.log
              JkLogLevel debug
      </IfModule>


Following are the contents of server.xml file
                      <!-- Define a Coyote/JK2 AJP 1.3 Connector on port
8009 -->
                      <Connector
className="org.apache.coyote.tomcat4.CoyoteConnector" port="8009"
minProcessors="5" maxProcessors="500" enableLookups="true" redirectPo
            rt="8443" acceptCount="10" debug="0" connectionTimeout="10"
useURIValidationHack="false"

protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler"/>

            .......

            <Engine name="Standalone" defaultHost="localhost" debug="0"
jmvRoute="tomcat0">

            ......


Regards
-AB


|---------+--------------------------->
|         |           Ashish-Kumar    |
|         |           BALYAN/IN/ALCATE|
|         |           L@ALCATEL       |
|         |                           |
|         |           06/23/2004 02:49|
|         |           PM              |
|         |           Please respond  |
|         |           to "Tomcat Users|
|         |           List"           |
|         |                           |
|---------+--------------------------->
  >---------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                        |
  |        To:      tomcat-user@jakarta.apache.org                                       
                        |
  |        cc:                                                                           
                        |
  |        Subject: AJP13 connection problem                                             
                        |
  >---------------------------------------------------------------------------------------------------------------|




Hi,

I have Apache and Tomcat running on two different SUN machines.
I get following error on trying to access a servlet.
Though things work fine if Tomcat and Apache are running on same machine.


[Tue Jun 22 15:09:01 2004]  [jk_uri_worker_map.c (460)]: Into
jk_uri_worker_map_t::map_uri_to_worker
[Tue Jun 22 15:09:01 2004]  [jk_uri_worker_map.c (477)]: Attempting to map
URI '/servlet/s4'
[Tue Jun 22 15:09:01 2004]  [jk_uri_worker_map.c (502)]:
jk_uri_worker_map_t::map_uri_to_worker, Found a context match loadbalancer
-> /servlet/
[Tue Jun 22 15:09:01 2004]  [jk_worker.c (132)]: Into
wc_get_worker_for_name loadbalancer
[Tue Jun 22 15:09:01 2004]  [jk_worker.c (136)]: wc_get_worker_for_name,
done  found a worker
[Tue Jun 22 15:09:01 2004]  [jk_lb_worker.c (527)]: Into
jk_worker_t::get_endpoint
[Tue Jun 22 15:09:01 2004]  [jk_lb_worker.c (310)]: Into
jk_endpoint_t::service
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (1404)]: Into
jk_worker_t::get_endpoint
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (1116)]: Into
jk_endpoint_t::service
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (295)]: Into
ajp_marshal_into_msgb
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (432)]: ajp_marshal_into_msgb
- Done
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (132)]: Into jk_open_socket
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (139)]: jk_open_socket, try to
connect socket = 7
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (148)]: jk_open_socket, after
connect ret = -1
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (177)]: jk_open_socket, connect()
failed errno = 146
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (626)]: Error connecting to
tomcat. Tomcat is probably not started or is listenning on the wrong port.
Failed errno =
 146
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (874)]: Error connecting to
the Tomcat process.
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (1190)]: sending request to
tomcat failed in send loop. err=0
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (132)]: Into jk_open_socket
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (139)]: jk_open_socket, try to
connect socket = 7
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (148)]: jk_open_socket, after
connect ret = -1
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (177)]: jk_open_socket, connect()
failed errno = 146
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (626)]: Error connecting to
tomcat. Tomcat is probably not started or is listenning on the wrong port.
Failed errno =
 146
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (874)]: Error connecting to
the Tomcat process.
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (1190)]: sending request to
tomcat failed in send loop. err=1
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (132)]: Into jk_open_socket
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (139)]: jk_open_socket, try to
connect socket = 7
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (148)]: jk_open_socket, after
connect ret = -1
[Tue Jun 22 15:09:01 2004]  [jk_connect.c (177)]: jk_open_socket, connect()
failed errno = 146
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (626)]: Error connecting to
tomcat. Tomcat is probably not started or is listenning on the wrong port.
Failed errno =
 146
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (874)]: Error connecting to
the Tomcat process.
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (1190)]: sending request to
tomcat failed in send loop. err=2
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (1198)]: Error connecting to
tomcat. Tomcat is probably not started or is listenning on the wrong port.
Failed errno
= 146
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (1388)]: Into
jk_endpoint_t::done, closing connection 0
[Tue Jun 22 15:09:01 2004]  [jk_ajp_common.c (561)]: In
jk_endpoint_t::ajp_close_endpoint
[Tue Jun 22 15:09:01 2004]  [jk_lb_worker.c (369)]: In
jk_endpoint_t::service, recoverable error... will try to recover on other
host
[Tue Jun 22 15:09:01 2004]  [jk_lb_worker.c (373)]: lb: All tomcat
instances failed, no more workers left.
[Tue Jun 22 15:09:01 2004]  [jk_lb_worker.c (380)]: In
jk_endpoint_t::service: NULL Parameters
[Tue Jun 22 15:09:01 2004]  [jk_lb_worker.c (389)]: Into
jk_endpoint_t::done



Regards
-AB



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org







---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message