tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Annie Guo <a...@appriss.com>
Subject RE: Form Authetication
Date Wed, 02 Jun 2004 15:07:00 GMT
I am trying to hook up JaasRealm.  When I enter username and password, my
LoginModule authenticates it ok from my debug statements.  But every time,
my page is forwarded to loginError.html instead of index.html that I want.
Below is what I have put in web.xml and server.xml.  Would anyone please
help let me know
what I have done wrong?

Thanks a lot.

in web.xml 
   <security-constraint>
        <web-resource-collection>
            <web-resource-name>Entire Application</web-resource-name>
            <url-pattern>/*</url-pattern>
        </web-resource-collection>
        <auth-constraint>
            <role-name>tomcat</role-name>
        </auth-constraint>
    </security-constraint>
    <login-config>
        <auth-method>FORM</auth-method>
        <form-login-config>
            <form-login-page>/loginJaas.jsp</form-login-page>
            <form-error-page>/loginError.html</form-error-page>
        </form-login-config>
    </login-config>

in server.xml

<Realm className="org.apache.catalina.realm.JAASRealm"
                     appName="Internal"
              userClassNames="com.appriss.tracker.InternalPrincipal"
              userRoleNames="com.appriss.tracker.InternalPrincipal"
                           debug="99"/>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message