tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: I'll kill JNDI
Date Sun, 13 Jun 2004 18:02:17 GMT
At 07:19 PM 6/13/2004 +0300, you wrote:
>Hi all,
>
>I've installed apache 2.049 + Tomcat 5.0.26 + PostgreSQL and i could 
>connect apache to tomcat after painful night with mod_jk2.
>So far so good.
>I could do regular jdbc connection by using traditional 
>Class.forName(ZOBARA) method to my existing fair pgsql.
>Then i wanted to try my first application's jdbc connection with DBCP Pool 
>exist on Tomcat. You know, we need it for bunch of reasons.
>I've read the documentation and also downloaded related JNDI reference 
>from sun (which is completely makes blah blah about LDAP)
>Check List;
>0. rh-postgresql3.jar copied to $CATALINA_HOME/common/lib and removed from 
>the all other locations.
>1. Server.xml changed for postgre jdbc driver as described. (Checked for 
>context tags)

What does "Checked for context tags" mean?  Either add the datasource stuff 
to <GlobalNamingResoruces> and provide a <ResourceLink> to it in your 
META-INF/context.xml or just define it completely in the latter.

>2. web.xml changed as described.
>3. My application connection element uses clear sample
>// Obtain our environment naming context
>Context initCtx = new InitialContext();
>Context envCtx = (Context) initCtx.lookup("java:comp/env");
>
>// Look up our data source
>DataSource ds = (DataSource)
>  envCtx.lookup("jdbc/mydb");
>
>4. Built this holly mess with ant by using build.xml
>5. Point to my page and see this
>"java.sql.SQLException: No connection"
>
>Is there any single one have an idea what's going on???
>I've double checked all the things. If anyone using postgreSQL with DBCP 
>please give me a hint.

Have you ever had this working with any database?  If so, then I'd suspect 
a bug in DBCP working with PostgreSQL.  However, if this is your first time 
using DBCP with Tomcat, I suspect it is something you did.  See my 
suggestion above and triple check everything.  If you still can't find 
anything wrong, post your config.


Jake


>Thanks
>Take care all
>
>
>Note: Turkish list fellows just drop me a line :=)
>
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message