tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Boutard <>
Subject Tomcat4 RMI class loading bermuda triangle
Date Wed, 23 Jun 2004 08:42:38 GMT
Hi every body,
I'm trying to fix this problem for one week and i'm turning crazy right now.
I have this servlet working perfectly, finding every package i put in 
/var/tomcat4/shared/lib except that it doesn't find my RMIServer class 
for casting
i get a
[java.lang.ClassNotFoundException] - myRMIServerClass
   org.apache.catalina.loader.StandardClassLoader.loadClass(Unknown Source)
   org.apache.catalina.loader.StandardClassLoader.loadClass(Unknown Source)
   java.lang.Class.forName0(Native Method)

all classes are in the jar with the stub and skeleton (i tried to put 
classes in WEB_INF/classes of my servlet but same problem... so i guess 
this is not the real problem)

I have set in catalina policy file a:
grant {
to be sure there's no problem of security. i changed the init.d/tomcat4 
script to add -security to the starting line to be sure that it is 
started the right way

I used to try the same code with tomcat 3 and i changed to tomcat 4 
because of a rmi jni problem reported on mailing lists (i spent so much 
time on tomcat4 that i can't remember what was the previous one) but i 
can't even get that far with tomcat4

My version is a rpm 4.2.1 for Red Hat

Does someone understand what's going on

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message