tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruth, Brice" <br...@fiskars.com>
Subject Re: Help! Moving app from TC4->TC5, blank pages, no errors!
Date Thu, 10 Jun 2004 16:05:28 GMT
Absolutely

Shapira, Yoav wrote:

>Hi,
>How strange... Is the behavior consistent across browsers, e.g. if you
>try IE or Opera?
>
>Yoav Shapira
>Millennium Research Informatics
>
>
>  
>
>>-----Original Message-----
>>From: Ruth, Brice [mailto:bruth@fiskars.com]
>>Sent: Thursday, June 10, 2004 11:52 AM
>>To: Tomcat Users List
>>Subject: Re: Help! Moving app from TC4->TC5, blank pages, no errors!
>>
>>The Access Log valve indicates that the error being generated is 404
>>    
>>
>...
>  
>
>>I still get a blank screen with no errors in the browser, and no errors
>>in Tomcat's logs. Here's the particular Access Log entry:
>>
>>10.5.201.20 - - [10/Jun/2004:10:49:23 -0600] "GET
>>/fiskars_PL/pl_PL/index.do HTTP/1.1" 404 - "-" "Mozilla/5.0 (Windows;
>>    
>>
>U;
>  
>
>>Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8"
>>
>>You'll notice that the request is a Struts Action ... what's going on
>>here?!?!?!? This application runs on TC5 just fine locally, same
>>    
>>
>version
>  
>
>>of TC5 ... why won't it run on the deployment server?!?!
>>
>>Shapira, Yoav wrote:
>>
>>    
>>
>>>Hi,
>>>So you're using TC-specific code in your webapp?  (Hence the need for
>>>different build files, one for TC4 and one for TC5, I imagine).
>>>
>>>Add logging output statements to your various filters so you can tell
>>>what they're doing, if anything.
>>>
>>>Enable the AccessLogValve to see if you're really getting 404s or
>>>something else (such as previous 5xx errors) are preventing normal
>>>processing.
>>>
>>>Yoav Shapira
>>>Millennium Research Informatics
>>>
>>>
>>>
>>>
>>>      
>>>
>>>>-----Original Message-----
>>>>From: Ruth, Brice [mailto:bruth@fiskars.com]
>>>>Sent: Thursday, June 10, 2004 10:58 AM
>>>>To: Tomcat Users List
>>>>Subject: Help! Moving app from TC4->TC5, blank pages, no errors!
>>>>
>>>>I'm in the process of taking an application that we've been deploying
>>>>
>>>>
>>>>        
>>>>
>>>to
>>>
>>>
>>>      
>>>
>>>>our production/stage/dev servers running TC4.1 to deploying it on our
>>>>dev server running TC5.0.18. On our local development workstations,
>>>>we've been deploying to TC5 for quite a while now, with no problems
>>>>        
>>>>
>...
>  
>
>>>>I'm not sure what the problem is deploying the web-app to TC5, but
>>>>        
>>>>
>the
>  
>
>>>>most confusing thing is that I'm not getting any errors!!!
>>>>
>>>>The 'welcome-file' for the application loads, and nothing else loads!
>>>>        
>>>>
>I
>  
>
>>>>can even put in a total garbage URL for that particular context and I
>>>>don't even get a 404 error or anything! The web-app is pretty
>>>>        
>>>>
>complex,
>  
>
>>>>with 5 or 6 filters chained together, so anywhere in there, something
>>>>may be happening to a request, but shouldn't I be getting exceptions
>>>>        
>>>>
>on
>  
>
>>>>STDOUT/STDERR?! I get nothing, not in stdout.log nor stderr.log, nor
>>>>localhost_log.2004-06-10.txt.
>>>>
>>>>When the web-app starts, it outputs some status information as it
>>>>        
>>>>
>goes
>  
>
>>>>through its bootstrapping (some custom messages, some Tiles messages,
>>>>some Validator messages) - and that all looks perfectly normal.
>>>>
>>>>I also have a Logger element in my context, and the log file
>>>>        
>>>>
>specified
>  
>
>>>>never gets created. Not sure why that would be, either.
>>>>
>>>>This is on a Win2K Server, with JDK1.4.2. I believe I'm running with
>>>>
>>>>
>>>>        
>>>>
>>>the
>>>
>>>
>>>      
>>>
>>>>"stock" server.xml, I've installed my context in
>>>>
>>>>
>>>>        
>>>>
>>>conf/Catalina/localhost
>>>
>>>
>>>      
>>>
>>>>as well as simply putting it in the META-INF directory of my exploded
>>>>WAR. I've tried loading from a packaged WAR as well as an exploded
>>>>        
>>>>
>WAR
>  
>
>>>>... no luck!
>>>>
>>>>The web-application is built using Ant and I've spent a good bit of
>>>>
>>>>
>>>>        
>>>>
>>>time
>>>
>>>
>>>      
>>>
>>>>developing our build process, so I'm fairly confident that its
>>>>        
>>>>
>working
>  
>
>>>>OK - I've used two different build files, one that builds the
>>>>application against TC4 APIs, the other uses the new TC5 APIs.
>>>>
>>>>I'm about at my wits end here ... I can't figure out what's going
>>>>        
>>>>
>on!!
>  
>
>>>>Especially without any errors or log output!!
>>>>
>>>>Respectfully,
>>>>Brice Ruth
>>>>
>>>>---------------------------------------------------------------------
>>>>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>>>>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>>>>
>>>>
>>>>        
>>>>
>>>
>>>
>>>This e-mail, including any attachments, is a confidential business
>>>      
>>>
>>communication, and may contain information that is confidential,
>>proprietary and/or privileged.  This e-mail is intended only for the
>>individual(s) to whom it is addressed, and may not be saved, copied,
>>printed, disclosed or used by anyone else.  If you are not the(an)
>>    
>>
>intended
>  
>
>>recipient, please immediately delete this e-mail from your computer
>>    
>>
>system
>  
>
>>and notify the sender.  Thank you.
>>    
>>
>>>---------------------------------------------------------------------
>>>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>>>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>>>
>>>
>>>
>>>      
>>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>>    
>>
>
>
>
>
>This e-mail, including any attachments, is a confidential business communication, and
may contain information that is confidential, proprietary and/or privileged.  This e-mail
is intended only for the individual(s) to whom it is addressed, and may not be saved, copied,
printed, disclosed or used by anyone else.  If you are not the(an) intended recipient, please
immediately delete this e-mail from your computer system and notify the sender.  Thank you.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>  
>

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message