tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joel <r...@ddcom.co.jp>
Subject Re: target release conflicts with default source?
Date Wed, 30 Jun 2004 03:06:02 GMT
> > ==========================
> >     [javac] Compiling 63 source files to 
> >             D:\Program_Files\jakarta\jakarta-tomcat
> >             -5.0.25-src\jakarta-tomcat-5\build\classes
> >     [javac] javac: target release 1.1 conflicts with default 
> >             source release 1.5
> > 
> > BUILD FAILED
> > ------------------------------------------------
> > 
> > I'm using Java 1.5 beta. Is that a no-no?
> 
> Quite strange... the option target 1.1 in javac is for compiling
> applet source in java1 for backward compatibility (due to the
> changing of byte code since java 1.3, if I remember correctly).

Okay, does this have something to do with, for instance, in 

    jakarta-tomcat-catalina/catalina/build.xml

the following:

    <!-- JDK flags -->
    <available property="jdk.1.2.present" classname="java.util.HashMap" />
    <available property="jdk.1.3.present" 
     classname="java.lang.reflect.Proxy" />
    <available property="jdk.1.4.present" classname="java.nio.Buffer" />

    <!-- Ant flags -->

that is, a lack of <available property="jdk.1.5.present"/>s?

-- 
Joel <rees@ddcom.co.jp>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message