tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ramesh" <ramesh.bo...@transerainc.com>
Subject Tomcat and JBoss
Date Wed, 30 Jun 2004 01:39:28 GMT
Hi,

 

I am using Tomcat 4.1 that comes packaged with JBoss 3.2.3. I am trying to
deploy my war which has two servlets.  I am not able to connect to my
servlets by doing a http://localhost:8080/ccgIntf. I tried different
variations of the URL but with no luck. I looked at the jmx-console and
found that the Servlets are not getting deployed. The war itself seems to be
but the Servlet Names are not appearing.

 

Can anyone tell me what I am missing?

 

Thanks,

 

Ramesh.

 

 

 

The structure for the war is

 

Tam.war

  |-- meta-inf

  |     |-- manifest.mf

  |-- web-inf

  |     |-- web.xml

  |     |-- jboss-web.xml

  |     |-- classes

  |     |      |-- my two servlet classes with directories.

 

The web.xml is:

 

<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application
2.3//EN" 

      "http://java.sun.com/dtd/web-app_2_3.dtd">

 

<web-app>

 

    <servlet>

        <servlet-name>ccgIntf</servlet-name>

 
<servlet-class>com.transerainc.tam.servlet.TAMServlet</servlet-class>

    </servlet>

 

    <servlet>

        <servlet-name>Statistics</servlet-name>

 
<servlet-class>com.transerainc.tam.servlet.StatisticsServlet</servlet-class>

    </servlet>

 

  <servlet-mapping>

    <servlet-name>ccgIntf</servlet-name>

    <url-pattern>/ccgIntf</url-pattern>

  </servlet-mapping>

 

  <servlet-mapping>

    <servlet-name>Statistics</servlet-name>

    <url-pattern>/stats</url-pattern>

  </servlet-mapping>

 

</web-app>

 

The Jboss-web.xml is:

 

<jboss-web>

      <!-- An empty context root map the war to the root context,

      e.g., http://localhost:8080/ -->

      <context-root />

</jboss-web>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message