tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barry Roberts <barry.robe...@xactsites.com>
Subject wc_get_worker_for_name, done did not found a worker - Plea for help
Date Tue, 01 Jun 2004 15:37:26 GMT
I'm getting desperate to get mod_jk working in apache on RHES 3 talking
to tomcat 5.0.19 on (another) RHES3.  I'm getting the error from the
subject line if I set JkLogLevel to "debug."  In the browser I see 500's
for ANY servlet.

I've tried the RHES3 apache2 rpms (httpd-2.0.46-25.ent), building
apache2 from source (2.0.49), building apache1 from source (1.3.31),
with mod_jk static or DSO.  Always the same thing.

I've played with the permissions on the workers.properties to world
readable, writable, and even executable.  I strace'd httpd and it
appears to successfully read the file (strace output below).

I even copied a known workers.properties from a production web server
(apache 2.0.43 built from source on Solaris) and it does the same
thing.  So I'm reasonably sure it's not a problem with the
workers.properties file itself.

I built mod_jk from the
jakarta-tomcat-connectors-jk-1.2-src-current.tar.gz tarball which
creates a jakarta-tomcat-connectors-jk-1.2.5-src directory.

I built my own version of mod_jk that logs in the map_get function in
jk_map.c and it appears that the map passed in the parameter jk_map_t *m
is null.  I've been trying to figure out why, and I'm just about stuck.

I have also tried mod_jk2 (with a workers2.properties) and it works
under low load.  Even with only 3 thread in siege I get "Broken Pipe"
errors in the tomcat logs and AjpGetReply errors in the jk logs.  I
think this is similar to bugs 28790 and/or 28532.  We also saw this in
our production servers, and our customers were seeing pages that just
never finished loading until we switched back to jk1.  So I could use
jk2 if I knew how to get around that, but jk1 would do, too.

Relevant (I think) strace output:

stat64("/usr/local/apache/conf/workers.properties",
{st_mode=S_IFREG|0777, st_size=788, ...}) = 0
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0xb75ea000, 4096)                = 0

from httpd.conf:

JkWorkersFile		/usr/local/apache/conf/workers.properties
JkLogFile		/var/log/mod_jk-a13.log
JkLogLevel		debug
JkMount			/apps/* lb

workers.properties:
worker.list=xsappa

worker.xsappa.port=139
worker.xsappa.host=192.168.2.40
worker.xsappa.type=ajp13
worker.xsappa.lbfactor=1


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message