tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Hanik - Dev" <devli...@hanik.com>
Subject Re: Tomcat 5.0.16 behind SSL Accelerator - 2nd post
Date Tue, 22 Jun 2004 14:18:42 GMT
how are you creating your links right now, the easiest is to just use relative links, like

<a href="/myapp/some.jsp">A Link</a>
here the browser will connect up using same protocol as the data came down on.

or you can create your own tag, like
<a href="<app:MyLink href="/myapp/some.jsp"/>">A link using tag</a>

Filip

----- Original Message ----- 
From: "Adrian Klingel" <adklinge@gpi.com>
To: "Tomcat User List" <tomcat-user@jakarta.apache.org>
Sent: Tuesday, June 22, 2004 8:20 AM
Subject: Tomcat 5.0.16 behind SSL Accelerator - 2nd post


> I searched for this in the archives at mikal.org, and only found the
> question and no answer.
> 
> I have Tomcat 5.0.16 behind a hardware SSL accelerator box.  The links in my
> webapps of course refer back to HTTP://myserver.com/myapp, but I of course
> want them to be rewritten as HTTPS://mysslaccelertor:port/myapp.
> 
> Is there a simple configuration change in the server.xml that I can make in
> order to fix this?
> 
> Thanks,
> Adrian Klingel
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message