tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Mehrle" <mich...@datasaur.com>
Subject Re: SSL and starting tomcat - issues
Date Sat, 05 Jun 2004 15:25:46 GMT
FYI:

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22388


----- Original Message ----- 
From: "Carl Olivier" <carl@zero-one.co.za>
To: <tomcat-user@jakarta.apache.org>
Sent: Saturday, June 05, 2004 6:56 AM
Subject: SSL and starting tomcat - issues


> Greetings.
>
> I am having some weird error when starting tomcat - the exception in the
> logs is:
>
> WARNING: Error registering contexts
> java.util.ConcurrentModificationException
> at java.util.HashMap$HashIterator.nextEntry(HashMap.java:782)
> at java.util.HashMap$EntryIterator.next(HashMap.java:824)
> at java.util.HashMap.putAllForCreate(HashMap.java:424)
> at java.util.HashMap.clone(HashMap.java:656)
> at
> mx4j.server.DefaultMBeanRepository.clone(DefaultMBeanRepository.java:56)
> at
> mx4j.server.MBeanServerImpl.findMBeansByPattern(MBeanServerImpl.java:1603)
> at
> mx4j.server.MBeanServerImpl.queryObjectNames(MBeanServerImpl.java:1568)
> at
> mx4j.server.MBeanServerImpl.queryMBeans(MBeanServerImpl.java:1512)
> at
> org.apache.coyote.tomcat5.MapperListener.init(MapperListener.java:136)
> at
> org.apache.coyote.tomcat5.CoyoteConnector.start(CoyoteConnector.java:1510)
> at
> org.apache.catalina.core.StandardService.start(StandardService.java:485)
> at
> org.apache.catalina.core.StandardServer.start(StandardServer.java:2298)
> at org.apache.catalina.startup.Catalina.start(Catalina.java:556)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
>
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39
> )
> at
>
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl
> .java:25)
> at java.lang.reflect.Method.invoke(Method.java:324)
> at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:284)
> at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:422)
>
> This results in none of the 49 contexts (hosts) to start correctly (or
> rather to be available).  When I request one of the hosts it returns a
HTTP
> 400 - Bad Request!
>
> If I retart Tomcat enough times - it does come up eventually!
>
> The only thing I have added is a HTTPS Coyote Connector - using a PKCS12
> keystore for a cert for ONE of the contexts (hosts)!  Nothing else has
> changed - and it has been running for a fairly long time!
>
> Any ideas?
>
> Carl
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message