tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: symLinks broken in tomcat 5.0.19
Date Tue, 11 May 2004 20:00:23 GMT

Hi,

>If I go to
>http://www.mydomain.com:8080/activeedit/ae.jsp I get a 404
>If I go to
>http://www.mydomain.com:8080/activeedit4.0/ae.jsp it works
>
>Activeedit is a symlink to activeedit4.0
>
>In the server.xml I have
><Resources className="org.apache.naming.resources.FileDirContext"
>allowLinking="true"  />

Where in server.xml is this?

>Am I missing something??

Yeah, a bunch: your symlink has the effect of deploying two different
contexts.  You have to be very careful with your configuration if you do
this: check your logs for any warnings or errors.

There are other ways to achieve what you're doing, including options
that were discussed today on the list.

Yoav Shapira



This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message