tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trond Hersløv <trond.hers...@gotogate.no>
Subject Tomcat virtualhost bug?
Date Tue, 25 May 2004 05:16:29 GMT
Hi, I need some help here.
 
Running: Apache 2.0.49, Tomcat 5.0.24 and jk2 2.0.4. Tomcat and the
webserver running on separate machines.
 
The webserver is set up with to virtualhosts. 
test1.athome.no
test2.athome.no
workers2.properties is set up so all *.jsp request are sent to Tomcat.
 
[channel.socket:172.20.201.92:8009]
 
[uri:/*]
 
On Tomcat I have to webapps: app1 and app2.
app1 should be for test1.athome.no
app2 for test2.athome.no
 
I thought everything was fine, BUT then I realized that I could access app2
like this: http://test1.athome.no/test2 <http://test1.athome.no/test2> .
What am I doing wrong?
 
<Host name="test1.athome.no" ..... appBase"webapps".....>
.....
.....
<Context path=""  docBase="test1" .....>
</Host>
 
The virtual host for test2 is set up in the same way. How can I prevent a
virtual host from having access to all the other webapplications?
 
I appreciate any help I can get.
 
Trond
___________________________________
it's 25.may and Norway is getting warmer
 
 
 
 


**********************************************************************
This email message has been swept by
MIMEsweeper for the presence of computer viruses.
**********************************************************************


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message