tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Spiegelberg, Eric" <Eric.Spiegelb...@redline.mckhboc.com>
Subject RE: Tomcat 5 Clustering VERY slow - waitForAck problem
Date Wed, 28 Apr 2004 14:06:22 GMT
I had a similar problem and after a little google'ing and surfing through
this mailing list I found that setting the shell variable LD_ASSUME_KERNEL
to a value of 2.4 fixes the problem.

I modified my Tomcat startup.sh scripts to include:

export LD_ASSUME_KERNEL=2.4

Thanks,
Eric

-----Original Message-----
From: Greg Hall [mailto:greg.hall@evo-mail.com]
Sent: Wednesday, April 28, 2004 3:36 AM
To: tomcat-user@jakarta.apache.org
Subject: Tomcat 5 Clustering VERY slow - waitForAck problem


Hi,

I have set up clustering between 2 Tomcat servers. The session 
replication  works but  is VERY slow. It appears  that the sending 
server does not receive an acknowledgement via the TCP socket and times 
out after 15 secs. The message I get is  as follows:

27-Apr-2004 21:51:54 org.apache.catalina.cluster.tcp.SocketSender waitForAck
WARNING: Wasn't able to read acknowledgement from server in 15000 ms. 
Disconnecting socket, and trying again.

Tomcat is running on Sun's VM 1.4.2_02 on RedHat Linux 9.

Any help greatly appreciated.

Regards,
Greg.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message