tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Taj" <martian20002...@hotmail.com>
Subject RE: Tomcat configuration
Date Sat, 03 Apr 2004 17:20:14 GMT
Under ROOT exists <myapplication> directory
The structure goes like :
<tomcat-home>
	<webapps>
		<ROOT>
			<myapplication>
			Html pages 
				<WEB-INF>
				Web.xml
					<classes>
						Class files

See whether u can help
If u have set ur server successfully, u would definitely know this one.
Thanks

-----Original Message-----
From: Shapira, Yoav [mailto:Yoav.Shapira@mpi.com] 
Sent: Friday, April 02, 2004 7:39 PM
To: Tomcat Users List
Subject: RE: Tomcat configuration


Hi,
What are your files under ROOT instead of just under webapps?

Yoav Shapira
Millennium Research Informatics


>-----Original Message-----
>From: Taj [mailto:martian20002001@hotmail.com]
>Sent: Friday, April 02, 2004 2:26 AM
>To: 'Tomcat Users List'
>Subject: Tomcat configuration
>
>Hi
>
>
>
>Iam having problem in setting my application running in Tomcat 4.1
>
>The applications directory is situated at
>/Tomcat4.1/webapps/ROOT/myapplication
>
>This is the only place that my pages are visible to the server.
>
>My class files are situated at
>/Tomcat4.1/webapps/ROOT/myapplication/WEB-INF/classes/
>
>
>
>The html pages in the directory /Tomcat4.1/webapps/ROOT/myapplication/
are
>visible to the server but my class files
>
>are not. I have tried everthing. The web.xml file is kept in the
directory
>/Tomcat4.1/webapps/ROOT/myapplication/WEB-INF/
>
>and the web.xml file goes like:
>
>
>
><web-app>
>
>
>
>   <servlet>
>
>                        <servlet-name>GetInput</servlet-name>
>
>                        <servlet-class>GetInput</servlet-class>
>
>   </servlet>
>
>
>
>   <servlet-mapping>
>
>                        <servlet-name>GetInput</servlet-name>
>
>                        <url-pattern>/GetInput</url-pattern>
>
>   </servlet-mapping>
>
>
>
></web-app>
>
>
>
>Where the GetInput in the servlet-name.
>
>
>
>The HTML page that calls the servlet has the following syntax for the
POST
>command:
>
>
>
><form method="POST" action="GetInput">
>
>
>
>I have also added to the environment variables of my OS, the following:
>
>
>
>CATALINA_HOME=E:\Program Files\Apache Group\Tomcat 4.1
>
>TOMCAT_HOME=E:\Program Files\Apache Group\Tomcat 4.1
>
>But to no difference
>
>
>
>Even after all this I get the 404 error: the required source was not
found.
>
>I would by very thankful to anyone who can find what I have missed and
help
>me out.
>
>
>
>Thanks
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>




This e-mail, including any attachments, is a confidential business
communication, and may contain information that is confidential, proprietary
and/or privileged.  This e-mail is intended only for the individual(s) to
whom it is addressed, and may not be saved, copied, printed, disclosed or
used by anyone else.  If you are not the(an) intended recipient, please
immediately delete this e-mail from your computer system and notify the
sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message