tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pitre, Russell" <RPI...@shawmut.com>
Subject [REPOST] CONNECTOR element help
Date Wed, 28 Apr 2004 14:20:43 GMT
Hello All-

I have a win2003 server box that I would like to use to host multiple
internal websites for my company.  I have 4 IP addresses on the box each
of which are assigned to a specific website.  3 of those websites are
hosted in IIS and the fourth website in Tomcat listening on the last IP
address and all website are using port 80.  No AJP connectors being
used.  The forth website has nothing to do with IIS.

IIS   ==>  172.20.100.10:80  
IIS   -->  172.20.100.11:80
IIS   -->  172.20.100.12:80
Tomcat 4.1.29  -->  172.20.100.13:80

In my server.xml (pasted below if you can decipher it) file I have only
one connector and the connector is set to listen on the corresponding IP
address using this attribute:   address="172.20.100.13"

Tomcat will not start up due to a port conflict.  I double checked all
of the websites in IIS to use their corresponding IP Addresses and
double checked Tomcat.  

I can not figure this out.  I searched all of the docs and googled for
the better part of yesterday afternoon and this morning.  If someone
could give me some insight I would much appreciate it.

SERVER.XML

 <Service className="org.apache.catalina.core.StandardService"
debug="0" name="Tomcat-Standalone">

<Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
address="172.20.100.13" acceptCount="50" bufferSize="2048"
compression="off" connectionLinger="-1" connectionTimeout="20000"
connectionUploadTimeout="300000" debug="0" disableUploadTimeout="true"
enableLookups="false" maxKeepAliveRequests="100" maxProcessors="75"
minProcessors="10" port="80"
protocolHandlerClassName="org.apache.coyote.http11.Http11Protocol"
proxyPort="0" redirectPort="8443" scheme="http" secure="false"
serverSocketTimeout="0" tcpNoDelay="true" tomcatAuthentication="true"
useURIValidationHack="false">

      <Factory
className="org.apache.catalina.net.DefaultServerSocketFactory"/>

    </Connector>

 

            <Engine className="org.apache.catalina.core.StandardEngine"
debug="0" defaultHost="localhost"
mapperClass="org.apache.catalina.core.StandardEngineMapper"
name="Standalone">

    

  <Host className="org.apache.catalina.core.StandardHost"
appBase="webapps" autoDeploy="true"
configClass="org.apache.catalina.startup.ContextConfig"
contextClass="org.apache.catalina.core.StandardContext" debug="0"
deployXML="true"
errorReportValveClass="org.apache.catalina.valves.ErrorReportValve"
liveDeploy="false"
mapperClass="org.apache.catalina.core.StandardHostMapper"
name="localhost" unpackWARs="true">

       

                        <Context
className="org.apache.catalina.core.StandardContext"
cachingAllowed="true"
charsetMapperClass="org.apache.catalina.util.CharsetMapper"
cookies="true" crossContext="false" debug="0" displayName="Tomcat
Manager Application" docBase="../server/webapps/manager"
mapperClass="org.apache.catalina.core.StandardContextMapper"
path="/manager" privileged="true" reloadable="false"
swallowOutput="true" useNaming="true"
wrapperClass="org.apache.catalina.core.StandardWrapper">

          <ResourceLink global="UserDatabase" name="users"
type="org.apache.catalina.UserDatabase"/>

        </Context>

        

<Context className="org.apache.catalina.core.StandardContext"
cachingAllowed="true"
charsetMapperClass="org.apache.catalina.util.CharsetMapper"
cookies="true" crossContext="false" debug="0" displayName="Shawmut
Portal Application" docBase="C:/DEV_WORK/LEGACY/build/war"
mapperClass="org.apache.catalina.core.StandardContextMapper" path=""
privileged="true" reloadable="false" swallowOutput="true"
useNaming="true"
wrapperClass="org.apache.catalina.core.StandardWrapper">

          <Logger className="org.apache.catalina.logger.FileLogger"
debug="0" directory="logs" prefix="portal_log." suffix=".txt"
timestamp="true" verbosity="10"/>

          <Resource name="portal" scope="Shareable"
type="javax.sql.DataSource"/>

          <ResourceParams name="jdbc/portal">

            <parameter>

              <name>url</name>

              <value>jdbc:JSQLConnect://server/database=portal</value>

            </parameter>

            <parameter>

              <name>driverClassName</name>

              <value>com.jnetdirect.jsql.JSQLDriver</value>

            </parameter>

            <parameter>

              <name>username</name>

              <value>sa</value>

            </parameter>

            <parameter>

              <name>password</name>

              <value></value>

            </parameter>

           </ResourceParams>        

                        </Context>

 

                        <Logger
className="org.apache.catalina.logger.FileLogger" debug="0"
directory="logs" prefix="localhost_log." suffix=".txt" timestamp="true"
verbosity="1"/>

      </Host>

      <Logger className="org.apache.catalina.logger.FileLogger"
debug="0" directory="logs" prefix="catalina_log." suffix=".txt"
timestamp="true" verbosity="1"/>

      <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
debug="0" resourceName="UserDatabase" validate="true"/>

    </Engine>

  </Service>



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message