tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emerson Cargnin <emer...@tre-sc.gov.br>
Subject Re: jk2 configuration
Date Wed, 28 Apr 2004 18:25:45 GMT
I had libapr0-2.0.47-63, installed it from de suse 9 distribution....

I installed apx2 with apache2 dev package, compiled ok, but tomcat gives 
me a message:

java.lang.UnsatisfiedLinkError: no jkjni in java.library.path

I set the relevant variable with:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/apache2

but i get the same error...

strange isn't???

Do I really have to use jni so to talk from and to apache using a file?????


Chong Yu Meng wrote:
> Hi Emerson,
> 
>  From the Tomcat error you quoted earlier, I could tell that APR is not 
> on your system. I assume you are using the Apache that comes with Suse. 
> I don't know what package APR comes under in Suse. WHen I do a search on 
> rpmfind.net, it says that for SUSE 8.1, it is called 
> apr-2.0.48-11.i586.rpm. Can you check if this package is installed on 
> your Suse system?
> 
> Also, can you try to locate your apxs manually ? Did you install the 
> devel package for Apache ? I think you will need it. Please see the 
> system requirements page of my Tomcat 5 document : 
> http://cymulacrum.net/writings/tomcat5/c840.html#JK2_INTEGRATION_SETUP
> 
> Note the packages that need to be installed. Since you are using SUSE, 
> you will need to find the equivalent names for these packages.
> 
> Regards,
> pascal chong
> 
> Emerson Cargnin wrote:
> 
>> Now I'm trying to build jk2 from source...
>>
>> my first problem was to find the apxs executable. It didn't existed. 
>> Looking at my distribution, I could find it at apache 1.3 developing 
>> package, I tought a kind of strange , but I did it, so I can find the 
>> apxs under /usr/sbin. But when I try to do the configure command:
>>
>> ./configure --with-apxs2=/usr/sbin/apxs --with-apr-lib=/usr/lib 
>> --with-tomcat-41=/home/emersonc/jakarta-tomcat-5.0.19
>>  --with-java-home=/home/emersonc/j2sdk1.4.2 --with-jni
>>
>> it gives the error:
>>
>> "configure: error: Do not use --with-apxs2 but --with-apxs"
>>
>> I changed for apxs knowing that there was something strange, and now I 
>> get the message:
>>
>> "configure: error: Apache 1.3 requires apr to built from source, use 
>> --with-apr and --with-apr-util"
>>
>> It looks that apache2 doesn't come with apxs, am I wrong?
>>
>> Emerson Cargnin wrote:
>>
>>
>>> Chong Yu Meng wrote:
>>>
>>>> Hi Emerson !
>>>>
>>>> 1. If you created the SHM file manually, can you delete it, then 
>>>> startup Tomcat and Apache and see if it works ?
>>>
>>>
>>>
>>>
>>> no
>>>
>>> but I just found out that catalina.out was spitting errors:
>>>
>>> 27/04/2004 14:41:53 org.apache.jk.server.JkMain start
>>> INFO: APR not loaded, disabling jni components: java.io.IOException: 
>>> java.lang.U                nsatisfiedLinkError: 
>>> /usr/lib/apache2/libjkjni.so: /usr/lib/apache2/libjkjni.so: 
>>>                                   undefined symbol: apr_md5_final
>>>
>>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 


-- 
Emerson Cargnin
Analista de Sistemas
Setor de Desenvolvimento de Sistemas - TRE-SC
tel : (048) - 251-3700 - Ramal 3181

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message