tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Egolf <ceg...@ugholf.net>
Subject Re: mod_jk2 2.0.4 compiler error on RHEL 3.0, Apache 2.0.46
Date Thu, 08 Apr 2004 13:26:07 GMT
Frank Fischer wrote:
 > did you manage to solve you're problem with this " gcc: cannot specify
 > -o with -c or -S and multiple compilations" error?
 >
 > I ran into the same problem on Fedora Core 1 with apache rpm.
 >
No, I haven't solved the problem on any RHEL 3.0 machines.   It seems to work or 
not work and nothing I try seems to fix it.  However, I glad that I'm not alone 
with this problem.

On Fedora Core 1, I had the same problem, but when I messed around w/ the 
'configure' options, I was able to get it working.  This is what worked for me 
on Fedora Core 1 using the Apache HTTP (and development) RPM's, Tomcat 4.1.29 
(and 4.1.30) binaries and the jk2-2.0.4 source:

     cd jakarta-tomcat-connectors/jk/native2
     ./configure --with-apxs2=/usr/sbin/apxs
     make
     cd ../build/jk2/apache2
     apxs -n jk2 -i mod_jk2.so


-- 
============================================================================
                                Chris Egolf
              http://www.ugholf.net     cegolf@ugholf.net
============================================================================


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message