tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Walter Truitt <walter.tru...@alcatel.com>
Subject Re: mod_jk2 build error
Date Fri, 02 Apr 2004 14:59:15 GMT
I would try making the directory for it possibly.

I don't know why it does this, but it puts a usr/local/apache2/modules
directory under the build directory.

/bin/cp ../../../build/jk2/apache2//usr/local/apache2/modules/mod_jk2.so
./../../build/jk2/apache2/mod_jk2.so
/bin/cp: cannot stat
`../../../build/jk2/apache2//usr/local/apache2/modules/mod_jk2.so': No such
file or directory

Since it is the copy that is failing, I would look at that.  

 -walter

> Hi,
> 
> I am trying to build the latest release of the JK2 connector:
> jakarta-tomcat-connectors-jk2-2.0.4-src. I'm running Red Hat Linux 9.0, Apache
> httpd-2.0.49 and Tomcat jakarta-tomcat-5.0.19.
> 
> I follow the directions in
> jakarta-tomcat-connectors-jk2-2.0.4-src/jk/native2/BUILD.txt
> 
>     cd jakarta-tomcat-connectors/jk/native2
>     ./configure --with-apxs2=/your/path/to/apxs
>     make
>     cd ../build/jk2/apache2
>     apxs -n jk2 -i mod_jk2.so
> 
> but the make fails with the following:
> 
> libtool: install: warning: remember to run `libtool --finish
> /usr/local/apache2/modules'
> /bin/cp ../../../build/jk2/apache2//usr/local/apache2/modules/mod_jk2.so
> ./../../build/jk2/apache2/mod_jk2.so
> /bin/cp: cannot stat
> `../../../build/jk2/apache2//usr/local/apache2/modules/mod_jk2.so': No such
> file or directory
> make[1]: *** [../../../build/jk2/apache2/mod_jk2.so] Error 1
> make[1]: Leaving directory
> `/usr2/download/jk/jakarta-tomcat-connectors-jk2-2.0.4-src/jk/native2/server/apache2'
> make: *** [jk2-build] Error 1
> 
> The ./configure step ends with the following:
> checking for rm... /bin/rm
> checking for grep... /bin/grep
> checking for echo... /bin/echo
> checking for sed... /bin/sed
> checking for cp... /bin/cp
> checking for mkdir... /bin/mkdir
> no apxs given
> need to check for Perl first, apxs depends on it...
> checking for perl... /usr/bin/perl
> building connector for "apache-2.0"
> checking checking for apache13...... not provided
> checking checking for apache20...... not provided
> checking checking for iis...... not provided
> checking checking for iPlanet...... not provided
> checking for tomcat33 location... not provided
> checking for tomcat40 location... not provided
> checking for tomcat41 location... not provided
> configure: creating ./config.status
> config.status: creating Makefile
> config.status: creating server/apache13/Makefile
> config.status: creating server/apache13/Makefile.apxs
> config.status: creating server/apache2/Makefile
> config.status: creating server/apache2/Makefile.apxs
> config.status: creating ../build.properties
> config.status: creating scripts/build/unix/dummy
> config.status: executing depfiles commands
> 
> I didn't have any problems with the previous JK2 version.  Can anyone give me a
> hint on how to resolve this?
> 
> Thanks much,
> -Tom
> 
> 
> __________________________________
> Do you Yahoo!?
> Yahoo! Small Business $15K Web Design Giveaway 
> http://promotions.yahoo.com/design_giveaway/

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message