tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Walter Truitt <walter.tru...@alcatel.com>
Subject Re: AGAIN jk2 2.0.4 compile
Date Thu, 01 Apr 2004 20:08:13 GMT
You shouldn't need to have APR, since it is included in apache 2.0.49.

Here, I will try to duplicate your issue.  I have a system running
Redhat 9.

cd /home/wtruitt/src
gzip -cd ../downloads/httpd-2.0.49.tar.gz | tar xf -
cd httpd-2.0.49
sh configure --prefix=/usr/local/apache2049 --enable-so
make
su -c 'make install'
su -
cd /usr/local
gzip -cd /home/wtruitt/downloads/jakarta-tomcat-5.0.19.tar.gz | tar xf -
chown -R wtruitt:wtruitt jakarta-tomcat-5.0.19
exit
cd /home/wtruitt/src
gzip -cd ../downloads/jakarta-tomcat-connectors-jk2-src-2.0.4.tar.gz | tar xf -
cd jakarta-tomcat-connectors-jk2-2.0.4-src/jk/native2
sh configure --with-apxs2=/usr/local/apach2049/bin/apxs
make
cd ..
su -c 'cp -p build/jk2/apache2/mod_jk2.so /usr/local/apache2049/modules'
cd /usr/local/jakarta-tomcat-5.0.19
bin/startup.sh
su -
cd /usr/local/apache2049/conf
# create workers2.properties
cat <<EOF >workers2.properties
[channel.socket:localhost:8009]
port=8009
host=127.0.0.1

[ajp13:localhost:8009]
channel=channel.socket:localhost:8009

[uri:/servlets-examples/*]
worker=ajp13:localhost:8009
EOF
# edit httpd.conf to add the following line
LoadModule jk2_module modules/mod_jk2.so

This worked for me.  I will have to look into the jni stuff that
someone else mentioned.

 -walter

From: Giorgio Ponza <giorgio@opla.it>
Subject: AGAIN jk2 2.0.4 compile
Date: Thu, 01 Apr 2004 16:53:05 +0200

> hi all again :D
> 
> I am trying to build tomcat connector 2.0.4 from source.
> I've read maby howto etc, but i didn't succeed.
> I installed apache 2.0.49 with --enable-so option
> Also tomcat 5.0.19. I am working on RH 9.
> I installed apr 0.9.4 in /usr/local/apr-0.9.4 and apr-util in
> /usr/local/apr-util-0.9.4
> 
> If i use the line ./configure --with-apx2=/usr/local/apache2049 it says:
> configure: error: Apache 1.3 requires apr to built from source, use
> --with-apr and --with-apr-util
> OK, so i set also that 2 options and i obtain
> configure: error: Use apr that comes with Apache 2, remove --with-apr
> OK again
> i tried to follow some FAQ suggestions like
> ./configure --with-apxs2=/usr/local/apache/bin/apxs
> --with-apr=/usr/local/src/apr-0.9.4
> --with-apr-util=/usr/local/src/apr-util-0.9.4
> with an error
> configure: error: Use apr that comes with Apache 2, remove --with-apr
> 
> and many others, mixed and remixed
> 
> do you have some advices? i'm not really good with linux, have i to
> installa apxs from a source different than apache2049?
> TX a lot
> Giorgio

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message