tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yair Fine" <fin...@bezeqint.net>
Subject RE: Problem with starting up Tomcat 5.0.1.9 using launcher - a classpath issue?
Date Sat, 03 Apr 2004 14:43:07 GMT
Did you mean tools.jar ? It is already in common\lib
I also have my CATALINA_HOME environement variable set (C:\Program
Files\Apache Software Foundation\Tomcat 5.0) 
It still don't work
Yair

-----Original Message-----
From: FRANCOIS Dufour [mailto:francoisdufour@hotmail.com] 
Sent: ש 03 אפריל 2004 15:48
To: tomcat-user@jakarta.apache.org
Subject: RE: Problem with starting up Tomcat 5.0.1.9 using launcher - a
classpath issue?


i ad the same ive red somwere to copy tool .jar to a folder in tomcat i
tink 
its comun/lib
not shure try to ad catalina_home environement variable  pointing to
your 
tomcat instalation folder




francoisdufour@hotmail.com
administrateur http://entre-nous.qc.tc





>From: "Yair Fine" <fineya@bezeqint.net>
>Reply-To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
>To: <tomcat-user@jakarta.apache.org>
>Subject: Problem with starting up Tomcat 5.0.1.9 using launcher - a
>classpath issue?
>Date: Sat, 3 Apr 2004 14:52:43 +0200
>
>Hi,
>I installed Tomcat 5.0.1.9 on Windows 2000.
>
>When I run Start menu-> programs -> Apache Tomcat 5.0 -> Start Tomcat ,

>nothing happens, and no tomcat icon appears.
>
>When i go to bin directory and run startup-using-launcher.bat , I get 
>an exception :
>java.lang.NoClassDefFoundError: org/apache/tools/ant/launch/AntMain
>         at java.lang.ClassLoader.defineClass0(Native Method)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
>         at
>java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
>         at
java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
>         at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
>         at
java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
>         at
org.apache.commons.launcher.Launcher.start(Launcher.java:385)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at 
>sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.ja
>v
>a:39)
>         at
>sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccesso
r
>Impl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:324)
>         at LauncherBootstrap.main(LauncherBootstrap.java:185)
>
>Indeed, if i look at ant.jar ion common\lib, there is no 
>org/apache/tools/ant/launch/AntMain class Though is if run startup.bat,

>the server starts and work I have my JAVA_HOME variable path going to 
>the right place
>
>Enyone have a clue ?
>Regards
>Yair Fine
>

_________________________________________________________________
MSN Search, le moteur de recherche qui pense comme vous !  
http://fr.ca.search.msn.com/


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message