tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yansheng Lin" <yansheng....@silvacom.com>
Subject RE: IOException: Stream closed error when using custom tags
Date Fri, 16 Apr 2004 20:20:51 GMT
Can you do a trace to see where it fails when you use <jsp:include>?  Is it
in doAfterBody() or doStartTag()?
Actually I don't quite understand your problem. You said it works fine when
you try to display it, but doesn't work when you set it as an attribute of
<jsp:include>.  Is that right?  If that's the case, normally what I would do
is break things up to two steps.  First get the url string, then set it in
the attribute.

-Yan

-----Original Message-----
From: shanmugampl [mailto:shanmugampl@adventnet.com] 
Sent: April 14, 2004 22:30
To: struts-user@jakarta.apache.org
Subject: IOException: Stream closed error when using custom tags


Hi All,

    I have a custom tag, which iterates through a data and provides a 
url to be included during every iteration. When i display the url as  a 
string, everything works fine. But when i try to include it through the 
<jsp:include> tag i am getting the following error.

java.io.IOException: Stream closed
	
org.apache.jasper.runtime.BodyContentImpl.ensureOpen(BodyContentImpl.java:62
4)

Once i get this error, reverting back to the old case(displaying the url as
a string) also throws the same error.
I cannot figure out the problem.

Also i have disabled tagpooling. Can anyone help me out on this.

Thanks
Shanmugam PL




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message