tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua J. Cox" <j...@once.com>
Subject apache/Jk problems
Date Tue, 24 Feb 2004 17:29:19 GMT
Converting some apache/tomcat systems from Webapp connectors to Jk 
using ajp13, I'm having problems getting apache/Jk to talk to Tomcat.  
I believe I've been very careful with the port assignments and whatnot, 
but continue to get failure, and the following error in the mod_jk.log:

ajp_connection_tcp_get_message: Error - Wrong message format 0x4854

I'm running tomcat 4.1.18 with Apache 2.0.48 in a Solaris 8 environment.
Any help that can be offered is much appreciated.

Here are some config file snippets, for your pleasure:

workers.properties:
--------------------------
worker.list=worker1

worker.worker1.port=8009
worker.worker1.host=tomcat-dev1
worker.worker1.type=ajp13
worker.worker1.lbfactor=1

server.xml connector:
-----------------------------
<Connector classname="org.apache.ajp.tomcat4.Ajp13Connector" 
port="8009"/>

httpd.conf:
----------------------------
LoadModule jk_module libexec/mod_jk.so
JkWorkersFile /usr/local/tomcat/conf/workers.properties
JkLogFile /usr/local/apache/logs/mod_jk.log
JkLogLevel debug
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
....
JkMount /loadbalance/* worker1


Joshua J. Cox, Unix Systems Administrator, @Once
direct.503.419.0550     reception.503.241.4185     mobile.503.449.7576


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message